Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Changing the Phantoms Internal Radio Frequancy

Discussion in 'Phantom FC40 Help' started by MarzBGx, Jul 13, 2014.

  1. MarzBGx

    Joined:
    Jun 26, 2014
    Messages:
    30
    Likes Received:
    0
    Location:
    England, Nottingmamshire
    I could do with some help please, on the FC40, I can see the 5Ghz Receiver and it has two plugs on it. My 2.4 Receiver with remote arrived and the Receiver only has place for one of the cables. What do I do? I will attach some photos

    Original 5G in Quad: http://prntscr.com/41khqg

    New 2.4 receiver: http://prntscr.com/41khx5
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Plug the cable coming from the X2 port on the NAZA to the pins on your new receiver. The cable in the X1 port is used for gimbal tilt control and the receiver you bought doesn't have a separate channel for that...it looks like the receiver from earlier models of the P1 rather than the receiver that's in the P1.1.1 and the standard P2 (which have both connections).
     
  3. MarzBGx

    Joined:
    Jun 26, 2014
    Messages:
    30
    Likes Received:
    0
    Location:
    England, Nottingmamshire
    Will check in the morning -- Morning: I have plugged the cable from the X2 port into the receiver in both orientations and the Phantoms LED indicator just flashes Orange rapidly. I can assume that the controller is connected to the receiver becasause when I turn on the transmitter the red light on the receiver disappears!?!? is there anything I need to look at in the Naza software?
     
  4. MarzBGx

    Joined:
    Jun 26, 2014
    Messages:
    30
    Likes Received:
    0
    Location:
    England, Nottingmamshire
    All done, had to change the receiver type in the Naza software, thanks for the help!