Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Aires6

    Joined:
    Apr 17, 2016
    Messages:
    2
    Likes Received:
    0
    Everything has been going great so far, until today!

    I just got a new iPad Pro 9.7" I went through my normal routine when connecting the DJI Controller, starting the app (yes i'm logged in), starting the controller and firing up the P4.

    The app doesn't even let me connect from the Equipment Screen, although i do have the option of seeing "How to Connect".

    P4 indicator lights are blinking Green in the rear and solid Red up front.

    I can start the motors and turn them off as well as being able to control the gimbal.

    Does anyone have ANY ideas?

    I tried my iPhone 6 and it works as it's supposed to, no issues.

    So my conclusion is it's the iPad not the controller!
     
    #1 Aires6, May 11, 2016
    Last edited: May 11, 2016
  2. stanfran

    Joined:
    Apr 15, 2014
    Messages:
    38
    Likes Received:
    2
    Location:
    Dedham, Ma USA
    Many people have had issues with IOS 9.3.1. I had it with my new iPhone 6s Plus this week. It seems to effect recent restores on devices.

    The common fix was a dfu restore. Back up your device using iTunes then restore it. You must use iTunes and Google dfu restore for procedure to reset phone before restoring. A regular iCloud restore will not work.

    This procedure worked for me.
     
  3. Aires6

    Joined:
    Apr 17, 2016
    Messages:
    2
    Likes Received:
    0
    Thanks so much Stanfran!

    What a hassle! fortunately had backed up my iPad Air 2 onto my Mac so everything went smoothly! Everything is now working as it should!

    Thanks again!