Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't upgrade H3-2D software?

Discussion in 'Phantom 2 Discussion' started by thatstevenguy, May 26, 2014.

  1. thatstevenguy

    May 26, 2014
    Likes Received:
    I have a Phantom 2 P330CB and I installed the H3-2D gimbal last night. I see that I need to update my RC to the latest version and I did this successfully. I launched the Phantom app (3.00) and went to look for updates. Everything is up to date. It says my gimbal has the latest version (1.2) and that there no updates but everywhere I have seen says I need to update the IMU to 1.8 so that I can use the new Phantom 2 RC tilt x1 pot on the back.

    Any clue how I could force the IMU to see that there is a new version?