Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't Get Samsung Galaxy S4 to Connect to DJI WiFi

Discussion in 'Phantom 2 Vision Discussion' started by James H, Dec 29, 2013.

  1. James H

    Joined:
    Dec 29, 2013
    Messages:
    16
    Likes Received:
    0
    Whenever I try to connect to the DJI Vision app on my Galaxy S4, it tries to connect to the correct DJI network, but then I get a "No Internet Connection" and it fails to connect. Anyone else with an S4 able to successfully connect to the DJI WiFi signal? If so, I'm all ears! Or I should say, all eyes!
     
  2. amrflyingdude

    Joined:
    Dec 18, 2013
    Messages:
    335
    Likes Received:
    0
    Same happens to me
     
  3. rrmader

    Joined:
    Dec 22, 2013
    Messages:
    8
    Likes Received:
    1
    Location:
    Pahrump NV
    Try putting it into Airplane mode that worked for me on a Samsung S3

    Rich
     
  4. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Common problem with some android phones - if you go into your Wifi Settings>Advanced settings you should find an option checked that forces the phone to only connect to wifi networks with a good internet connection. This means your phone will dump the Vision network in the presence of another network it recognises with internet access. If you uncheck that option you should find you stay locked onto the Vision network with no problem.

    Hope that solves it for you.
     
  5. amrflyingdude

    Joined:
    Dec 18, 2013
    Messages:
    335
    Likes Received:
    0
    I couldn't find that option, I do believe you are right however. Mine sys testing connection then refuses to connect because does not find internet in that IP address.
     
  6. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Here's where I find it (but note I'm running a Nexus 4, so it's plain vanilla KitKat build - other OEMs might have tweaked menus a bit...):

    Go to Settings>Wifi>Advanced(that's found in a dropdown on the bottom or top of that screen, either 3 vertical dots or 3 lines, depending on yourflavour of android)>Uncheck "Avoid poor connections".
     
  7. amrflyingdude

    Joined:
    Dec 18, 2013
    Messages:
    335
    Likes Received:
    0

    Well that is a little bit different for the S4... Do the same but instead of unchecking "Avoid Poor Connections" uncheck "Auto Network Switch" That force the phone to connect to whatever you want.
     
  8. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Good stuff!
     
  9. James H

    Joined:
    Dec 29, 2013
    Messages:
    16
    Likes Received:
    0
    Still not finding where to uncheck "Auto Network Switch" in the S4.
     
  10. amrflyingdude

    Joined:
    Dec 18, 2013
    Messages:
    335
    Likes Received:
    0
    Try this.

    Swipe from top to bottom (to get to notifications screen)
    On the upper right corner click on the white gear
    Click on wi fi
    click on the menu button (right to the left of the home button)
    click the first option on the newly appeared menu (advanced)
    uncheck "Auto Network Switch"

    Hope this helps.
     
  11. James H

    Joined:
    Dec 29, 2013
    Messages:
    16
    Likes Received:
    0
    Clear as day. Thanks so much! And thanks to all who responded to my post. Never expected this rapid response AND solution!
     
  12. spazmodic1

    Joined:
    Dec 20, 2013
    Messages:
    26
    Likes Received:
    0
    Hi,

    This isn't really an answer to your question but is an app called wifi prioritizer, you can set the preferred networks to connect to is quite handy. So it doesn't jump back to your home wifi.

    A little problem of my own. After updating the firmware on the s4, the wifi signal strength indicator does not work. when i connect it to my ipod it works fine. No big deal just some sort of glitch somewhere.

    Also does anyone out there have the problem if they loose connection with the vision while flying they loose the live stream? seems that sometimes when i fly out of range i will get a frozen screen and i have to power cycle the drone, phone and repeater. Still get the telementery but just loose the picture. can be quite annoying.
     
  13. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    I get this occasionally, spazmodic, but I don't find I need to reboot everything. Usually just backing out of the live view into the app menu then selecting the Vision camera again clears it for me (Nexus 4, Kitkat)
     
  14. dav5942

    Joined:
    Nov 4, 2013
    Messages:
    26
    Likes Received:
    0
    Found that had to turn off GPS on S4 to get WiFi to work.
     
  15. MikeySoft

    Joined:
    Feb 21, 2014
    Messages:
    200
    Likes Received:
    1
    Location:
    Boston, MA, USA
    I have a nexus 5 and don't have problems connecting to the vision other then sometimes it taking longer then I would like. I have "Avoid poor connections" unchecked. I have the advance option " WiFi optimization (Minimization battery usage when Wi-Fi is on)" checked. Has any experimented with this option?
     
  16. Erroneous007

    Joined:
    Feb 12, 2014
    Messages:
    42
    Likes Received:
    0
    I has the same issues with the HTC One disconnecting, I finally had to put it int airplane mode and then turn the wifi back on while in AP mode and connect. It stayed connected then.