Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't get it to link no matter what I do

Discussion in 'General Discussion' started by RadioWolfman, Aug 12, 2016.

  1. RadioWolfman

    Joined:
    Aug 12, 2016
    Messages:
    1
    Likes Received:
    0
    Hi all,
    I bought a Phantom 2 Vision + when they first came out and put it in a cupboard to set up a bit later. Finally got it out yesterday and it flies but I can't get the range extender or my iPhones/iPads to link with the helicopter.
    I have done a plethora of different "Fixes" gleaned from the web and from DJI but nothing works. I get nothing from the helo as a wifi connection.
    The range extender system lights blinks very, very slowly and when I try to rebind it does not shut off and restart, just keeps flashing very slowly.
    Starting to get frustrating as it is hopefully something with the phones/pads but nothing comes up on the iMac either.

    Anybody out there have similar problems that they have fixed. Seems to be a regular problem.

    DJI don't seem to want to know just sell a new one.
     
  2. EMCISME

    Joined:
    Jan 10, 2015
    Messages:
    57
    Likes Received:
    2
    You say it doesn't shutdown offer the rebound. I don t quite understand what you mean. I've recently rebound mine. It didn't shut itself down, I had to power it all off. There is a terrific video on the web from a business calling themselves, "drones made easy". Follow those instructions and it will surly bind. Do you have a working. Camera installed? You've likely read that the wifi module is peered through the camera port. The power literally goes through a camera Cabot and comes back through another set of wires. It's wired in series such that if there is no camera, of if the widest cable is unseated, the wifi module gets no power. Do you see the wifi SSID coming from the extender?


    Sent from my iPhone using PhantomPilots