Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Cant connect to litchi

Discussion in 'Phantom 3 Help' started by keevan, Aug 29, 2016.

  1. keevan

    Joined:
    Mar 11, 2016
    Messages:
    48
    Likes Received:
    1
    Only connected to litchi 3 times after 1/2 hour fiddling each time. Any way to force connection when stays disconnected? I need some help and suggestions.
     
  2. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    I've had issues on my Samsung Galaxy Tab S2 with Litchi. In my case you can't have DJI Go installed in order for it to connect. Even if the DJI GO app is force closed Litchi won't connect. I hope Litchi fixes this soon. Give it a shot, if yours is similar to mine It will work after uninstalling DJI GO.
     
  3. keevan

    Joined:
    Mar 11, 2016
    Messages:
    48
    Likes Received:
    1
    Thanks for the tip, Ryan. I will certainly give that a try ASAP.
     
  4. keevan

    Joined:
    Mar 11, 2016
    Messages:
    48
    Likes Received:
    1
    I uninstalled DJI and icons disappeared but litchi still will not connect
     
  5. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    What type of tablet do you have? Have you restarted since uninstalling?
     
  6. keevan

    Joined:
    Mar 11, 2016
    Messages:
    48
    Likes Received:
    1
    Success! Would not connect after uninstalling so as a last resort, I changed usb cable and BINGO, connected right away and flew 2 good missions. Was a short white cable that seemed OK for charging but nothing else.
     
  7. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    I have Litchi on my phone and dji go on a separate tablet. No conflicts there! Tend to use Litchi as primary.
     
  8. Frank chrome

    Joined:
    Sep 9, 2016
    Messages:
    6
    Likes Received:
    0

    Hi I just bought the galaxy s2, using it in the phantom 4 and it will not connect. I don't have the dgi go installed but this litchi wont connect. Does anyone have a solution for this.
     
  9. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    I had the same problem you have to add a second user on your Samsung tablet and only have DJI go installed on one of them and litchi installed on the other user
     
  10. Frank chrome

    Joined:
    Sep 9, 2016
    Messages:
    6
    Likes Received:
    0
    Hi ryantrax. Not sure I understand. How do you add a second user? At the present all that is installed is litchi, dji go I Uninstalled it.
     
  11. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Do you have the Galaxy tablet S2 or the phone? On the tablet you can add a second user.
     
  12. Frank chrome

    Joined:
    Sep 9, 2016
    Messages:
    6
    Likes Received:
    0
    I have the galaxy S2
     
  13. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Oh I don't think you can add a second user on that phone. For now until it is fixed I think your only option is to make sure you only have one of the programs installed at a time.

    Sent from my SM-N920V using Tapatalk
     
  14. Frank chrome

    Joined:
    Sep 9, 2016
    Messages:
    6
    Likes Received:
    0
    That's exactly what I have. I only have one app installed which is litchi and nothing else and I does not connect which is my original problem.