Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't charge battery

Discussion in 'Phantom 1 Help' started by Djeffries15, Jan 3, 2014.

  1. Djeffries15

    Joined:
    Jan 3, 2014
    Messages:
    1
    Likes Received:
    0
    I'm a newbie. Got the Phantom for Xmas, charged the batteries, and it flew fine.
    Batteries died down and I've tried to recharge. ( I have a BC20-4 balance charger). When I plug up to the charger I'm getting alternating red flashing lights - "Charge Status " and "1s". It's set on LiPo and 1A.
    I don't think I should be seeing those two lights blinking. It's not charging.
    What am I doing wrong?
     
  2. cczx14r

    Joined:
    Sep 27, 2013
    Messages:
    45
    Likes Received:
    0
    Set it on "2A".
    When your battery is approx. 80% charged, you'll see alternating red-green lights for 5 - 10 minutes, then it'll go solid green when done. You'll see a solid red light up to the 80% charged point. The smaller 1S, 2S and 3S lights are solid throughout the charging process.
     
  3. jimopar

    Joined:
    Apr 20, 2013
    Messages:
    6
    Likes Received:
    0
    Remember you must ALWAYS connect both connectors to a balance charger. If you only connect the bigger yellow one it won't have the individual cell voltages to properly charge each cell to the correct voltage. Not sure if that's the problem, but thought I'd mention it.
     
  4. leprechaun

    Joined:
    Jan 2, 2014
    Messages:
    7
    Likes Received:
    0

    Hi don't want to hijack thread but today I charged my battery for the second time from new . I plugged all in and it started to charge . When I cam back after some hrs there were no green light indicators on however when I press the button to check battery I get all the green leds lit up . I thought when battery was fully charged up that all green lights stayed lit ?

    Thanks