Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Cannot see any video on iPhone 6+

Discussion in 'Phantom 2 Vision + Discussion' started by plasmo, Oct 11, 2014.

  1. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    I finally got around to setting up my new iPhone 6+ to test it out on my P2V+.

    For some reason I just a spinning "thinking" wheel that keeps spinning, but no picture.
    I can control the movement of the camera with the phone and all the parameters seem correct.

    Anyone know how to fix?
    The camera was working perfectly the last time using my old iPhone 5.

    Screenshot attached. Thanks
     

    Attached Files:

  2. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    Have you tried closing some of your open apps? I find that times where I can't get video to load... It is sometimes caused by all the other apps working in the background. I don't have a vision plus so this is just speculation on my part... But I thought it worth mentioning.

    Close all extra apps and restart the phone... And see if that helps.
     
  3. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    Will try and let you know. Thx
     
  4. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    Nope. Didn't change anything after I closed all the background apps. I will try to do a reboot on the iPhone next.
     
  5. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    Ugh. Nothing works. I reset the iPhone and also reinstalled the Vision app.

    Anyone using an iPhone 6+ get theirs to work ? Maybe the phone is not compatible ?
     
  6. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    I just tried using my sons iPhone 4 and installed the Vision software. It does the same thing. Everything works except the video with just a spinning wheel. Both phones are running latest iOS 8.02 which is different from my old iPhone 5 that I was previously using (sold it)
     
  7. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    I just put in fresh new AA batteries into the controller. Still doesn't work :(
     
  8. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    I saw this post above. If this is the case, I will be quite upset.
     
  9. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    No I have the booster app but did not use it at all when discovering this issue. Plus I tried another iPhone and it does the same thing.
    Unfortunately I don't have my old iPhone (that worked fine) anymore.
    One thing about the other thread regarding the wifi module- it would work okay for them until it heated up for a while and then fail. Mine doesn't work from cold start. Plus I haven't had any physical damage or jolts since the last time it was working fine. Ugh
     
  10. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    So the PVFlyer booster app can possibly fry our wifi modules? This should be stated outright as a possibility in their app ad. I think I used the booster about 5-8 times.
     
  11. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    thanks, will research this prior to ordering another Wifi Module.

    What sucks is that I would say I have flown my bird fairly "lightly" with only about 40 flights (or less) prior to wifi fail, while I'm reading others that have have had 100+ flights prior to this happening.
     
  12. samd012

    Joined:
    Jun 18, 2014
    Messages:
    141
    Likes Received:
    4
    Definitely sounds like the wifi module, did you try to unbind then rebind as a last resort before purchasing a new one, I think they run like $99.
    Just for people who may be concerned my 6+ works perfectly with pv2+
     
  13. Renegade

    Joined:
    Dec 11, 2013
    Messages:
    8
    Likes Received:
    1
    Location:
    Texas
    Does it work with anything else?

    Mine works fine with iPhone6 as well as iPad3 running ios8.
     
  14. BennyGca

    Joined:
    Oct 8, 2014
    Messages:
    20
    Likes Received:
    0
    Location:
    Montreal, Canada
    I really wouldn't be surprised if it's just the update to iOS8. A lot of my old apps didn't work properly after I updated from iOS7.. I just had to wait for the apps to have updates before being able to use again.

    Just fire off an email to DJI and ask if the app optimized for iOS8 is out yet.
     
  15. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0

    I will try to unbind and rebind as last resort before i buy.
    DDM sells the wifi module for $189.
     
  16. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    @samd012-

    I assume your iPhone 6+ is running the latest iOS 8.0.2 right?
    If it works, that would mean iOS8 works with the latest Vision App i presume....
     
  17. saao

    Joined:
    Aug 17, 2014
    Messages:
    324
    Likes Received:
    0

    Dude I am using an iPhone 6plus with 8.02 no problems at all something else is wrong at ur side...!
     
  18. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    Thanks for confirming this.
     
  19. vortigern

    Joined:
    May 28, 2014
    Messages:
    163
    Likes Received:
    3
    This is a weird problem which is solved by buying a new WiFi module. As it is exactly the same as the original why it is a cure is a mystery. My people at RC Geeks cannot explain why but changing works. I thought that the left hand connection was loose fitting which might be worth checking but it was probably not the reason.
     
  20. samd012

    Joined:
    Jun 18, 2014
    Messages:
    141
    Likes Received:
    4
    My ipad and iphone are on ios 8 and work perfectly