Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Cannot get Samsung Mega (Andriod) to connect to controller

Discussion in 'General Discussion' started by jon bondy, Nov 13, 2015.

  1. jon bondy

    Joined:
    Nov 13, 2015
    Messages:
    3
    Likes Received:
    0
    First timer. I power up the controller and the drone, and all is well: I can control the camera from the controller. I then connect the Mega to the controller, but the DJI App will not connect to the controller. Is there some trick? I tried disabling WiFi.

    I can connect as either a media device, or as a camera. Neither mode works. Do I need any additional software loaded onto the Android?

    Thanks!

    Jon
     
    #1 jon bondy, Nov 13, 2015
    Last edited: Nov 13, 2015
  2. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,943
    Likes Received:
    1,149
    Location:
    Brookeville, MD, USA
    First thing you need to tell us is what you are trying to fly.
     
  3. jon bondy

    Joined:
    Nov 13, 2015
    Messages:
    3
    Likes Received:
    0
    Sorry. Phantom 3 Pro
     
  4. jon bondy

    Joined:
    Nov 13, 2015
    Messages:
    3
    Likes Received:
    0
    I found the answer here:

    DJI Forum|Cannot Connect the Phantom 3 Remote Controller to the Samsung tablets.


    You may need to enable USB debug mode.. I had to on my Tab S2

    1: Ensure your device is not connected to another device via the USB cable.
    2: From the Home screen, select “Apps” > “Settings“.
    3: Select “General” at the top of the screen.
    4: Scroll down on the left pane and select “About device“.
    5: Tap the “Build number” area 7 times. You should get a message that indicates developer mode is enabled.
    6: You should now have a “Developer options” selection available on the left pane. Select it.
    7: Under the “Debugging” area, check the “USB debugging” check box.