Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can you use the same App with the P2V-plus and the P2V?

Discussion in 'Phantom 2 Vision + Discussion' started by gcoxusa, Sep 27, 2014.

  1. gcoxusa

    Joined:
    Feb 20, 2014
    Messages:
    20
    Likes Received:
    3
    I have a Phantom 2 Vision. It has been working quite well for over 6 months. I have plenty of video to show which was recently in the local news. I needed more FPV range so I purchased the newer extender (RE700) and again this has been working very well. I was using the DJI app version = 1.0.38 with a Samsung Galaxy S4.

    But I wanted more controller range and better video so I purchased a new P2V-plus with the gimbal. The app I was using with the P2V does not work very well with the plus model. I had no control over the camera gimbal. So I updated the app to the current 1.0.52. Things are working well now with the stock P2V-plus.

    But now with the updated app the camera FPV does not work with my original P2V. What I mean is that the image I am seeing on my phone is now a garbled mess and useless. I have changed camera setting, rebooted the camera, re-charged everything, and this problem will not go away. I assume the problem is with the app since that is ONLY thing that changed with my P2V setup.

    I hope I don't have to buy another smart phone just to use a different app version. Any thoughts or suggestions would be appreciated. Maybe I need to downgrade the app if that is possible.
     
  2. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    I use the same app across the two aircraft without issue. You might find you have to reduce the quality/frame rate of the FPV stream when moving from one aircraft to the other, later versions of the app have changed the default which may be the problem with your Vision.
     
  3. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    If you are having problems with 1.0.52, try going back to 1.0.39. That version should work with both and it was the first version that gave you tilt control for the V+ so tilting won't be an issue. I am currently using 1.0.39.
     
  4. Skynet1

    Joined:
    Apr 20, 2014
    Messages:
    192
    Likes Received:
    12
    Hey DB,
    You always seem to be so helpful to so many, if you get a few minutes could you take a look at the PM I sent you a few days ago ? ; )
     
  5. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Sorry I missed your message somehow. Sent you a reply.