Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware Can downgrade but with Barometer errors

Discussion in 'Firmware' started by NATEHAWK, Mar 18, 2017.

  1. NATEHAWK

    Joined:
    Feb 24, 2017
    Messages:
    17
    Likes Received:
    0
    Here's my issue, I can get my P3S to downgrade to 1.7.9 but I get a barometer error. When I go to the IMU it says I need to calibrate it. Once calibrated Im still having the same issue showing I have a barometer error. I can upgrade back to 1.8.10 and all is fixed. Then I come on here and see people who have downgraded from 1.8.10 with no errors at all. What are you doing and what am I not doing? Take a look at my log file attached hopefully that can have some insight. Any help would be appreciated
     

    Attached Files:

  2. Eduardoruizgr

    Joined:
    Apr 11, 2017
    Messages:
    3
    Likes Received:
    0
    I have the same error as you, Have you found any responses to this? I can downgrade but I get the barometer error and once I upgrade to 1.8.1 It works fine but the range is bad
     
  3. KennethMcNutt

    Joined:
    Oct 23, 2016
    Messages:
    142
    Likes Received:
    32
    1.7.9 downgrade "Sensor Error" Fixed!!!
    Just some background....
    When some drones updated from 1.6.8 to 1.7.9 they got sensor errors... So DJI released 1.7.94 to fix them..
    So....I have just found your ... Solution???
    It was simple??
    But it has to be done in this order..
    Assuming you're still at 1.8.1..
    If you are 1.8.1 + debug it first...
    Then...
    Downgrade to 1.7.9.. Get the error... Restart Still Sensor error...

    Rerun F/w 1.7.9 with debug... Still Sensor error...Cal the Imu (yep)... still get the error.. :(

    Update with 1.7.94 No more error?? [​IMG]
    Recal Imu [​IMG], please?
    This is the setups I just took to fix it for a member of our group...
    So I am not Sure if any IMU cals were.... anything more than a waste of time..


    P3S P3/4K downgrade Possible !?! ALL the WAY back!!! (Confirmed Working to 1.5.7!!!)
     
Loading...