Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera works fine, but gimbal movement stops sometimes.

Discussion in 'Phantom 2 Vision + Discussion' started by kmad86, Oct 14, 2014.

  1. kmad86

    Joined:
    Oct 14, 2014
    Messages:
    4
    Likes Received:
    0
    Hey guys. I am new around here. We picked up a P2V+ a while back. It hasn't ever been crashed, but lately I have had some issues with the gimbal. The camera will work fine, but the gimbal will just stop working completely. Being new around here, I searched around a bit but was thinking maybe I wasn't searching the right variables to yield the results I was looking for. I'm sure I am not one of the only ones that have had this issue. We're in the electronic repair business, so I don't mind digging into it and repairing the unit if necessary.

    Also, sometimes my wifi link to the phone will disconnect.

    I found this link.
    viewtopic.php?f=27&t=20514

    Would this type of repair possibly cure the issue that I am having?
     
  2. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    16
    What you are describing is a intermittent connection. The fix you linked to involves flopping twitching out of level cameras. I would check your grey wire gimbal connectors for continuity.
     
  3. kmad86

    Joined:
    Oct 14, 2014
    Messages:
    4
    Likes Received:
    0
    The connectors on the camera are seated fine, but I will have to dig in a little further internally in the unit to see if those are fine.
     
  4. kmad86

    Joined:
    Oct 14, 2014
    Messages:
    4
    Likes Received:
    0
    It's the camera flex cable. It was never wrecked, but I can see where there's a fine tear in it about 1/4th the way through. I guess I will have to bite it and order one for 85 dollars.