Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera won't work

Discussion in 'Pro/Adv Discussion' started by alancan2, Jan 31, 2016.

  1. alancan2

    Joined:
    Dec 12, 2015
    Messages:
    6
    Likes Received:
    0
    So have not flown in month because of weather , powered up everything and now camera does not show image and goes limp after start up, any tips on how to fix this.
     
  2. DroneDestination

    Joined:
    Jan 15, 2016
    Messages:
    698
    Likes Received:
    126
    Check ribbon cable(s) for damage or loose connectors
     
  3. tyson199

    Joined:
    Jun 9, 2015
    Messages:
    25
    Likes Received:
    15
    Batteries fully charged ? Mine did that once because battery wasn't charged properly
     
  4. alancan2

    Joined:
    Dec 12, 2015
    Messages:
    6
    Likes Received:
    0
    Cables look fine . What next , now on boot up camera turns to left kinda sits there for moment then goes limp.
     
  5. alancan2

    Joined:
    Dec 12, 2015
    Messages:
    6
    Likes Received:
    0
    Battery full charged , soft ware is 1.6 on quad and 1.5 on controller. Dji app updated before this started, any one else having problem after update.
     
  6. Trackman1

    Joined:
    Jan 1, 2016
    Messages:
    838
    Likes Received:
    212
    Location:
    Ontario, Canada
    Does SD card in gimbal have .bin file on it?
     
  7. alancan2

    Joined:
    Dec 12, 2015
    Messages:
    6
    Likes Received:
    0
    Try ed it with 3 different SD cards with and without bin file. It is like the camera is not conected , after boot up it is like it just turns off camera.
     
  8. alancan2

    Joined:
    Dec 12, 2015
    Messages:
    6
    Likes Received:
    0
    So held down sync button for controller powered up quad released after it beeped , turned on controller and booted up phone , it beeped for 26 min and now works great. Thanks to all of you on the form would not have got it with out you.