Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera Twitching After Upgrade

Discussion in 'Phantom 2 Vision + Help' started by Walboy, Dec 11, 2015.

  1. Walboy

    Joined:
    Dec 11, 2015
    Messages:
    8
    Likes Received:
    0
    I upgraded my Phantom to the latest firmware and went to do a video today but the camera kept twitching and I got messages on my tablet. In-flight it got worse and the gimbal actually turned to the side and was recording part of the leg.

    The Phantom has never been crashed and it was working 100% perfect before the upgrade so its clearly some firmware issue that I don't know how to fix.

    Can anyone help?
    Thanks in advance.

     

    Attached Files:

  2. Walboy

    Joined:
    Dec 11, 2015
    Messages:
    8
    Likes Received:
    0
    I set it to Naza then back to default and its a little better but still a slight twitch which is extremely annoying. I thought firmware was suppose to help any issues not cause them.
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    You need to redo an adv imu calibration after firmware update. Dont fly phantom for an hour. Find a levelled area. Do the imu calibration the moment you turn in the phantom. The cooler the phantom, the faster and more accurate the calibration.

    The twitching is also compass related. So a do a dance in an open field as well.
     
    Walboy likes this.
  4. Walboy

    Joined:
    Dec 11, 2015
    Messages:
    8
    Likes Received:
    0
    Perfect thank you, all seems to be working again now :)
     
  5. Walboy

    Joined:
    Dec 11, 2015
    Messages:
    8
    Likes Received:
    0
    I spoke too soon, back to square one.

    The camera is still twitching. I went to record a video today but the twitching camera prevented me from doing one.

    All the Phantom is good for is taking photos. I am not very impressed at all.
     
  6. Squiddley

    Joined:
    Dec 29, 2014
    Messages:
    650
    Likes Received:
    244
    Location:
    Yorkton Sask Canada
    did you calibrate the gimbal after the firmware update?
     
  7. Walboy

    Joined:
    Dec 11, 2015
    Messages:
    8
    Likes Received:
    0
    Yes I did and still had the same problem. After about 5 flights it has sorted its-self out :) but I still get the odd message saying to check the gimbal for an obstruction but I just ignore it.