Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera not working on Phantom 2 Vision +

Discussion in 'Phantom 2 Vision + Discussion' started by dgravitt, Jun 8, 2016.

  1. dgravitt

    Joined:
    Mar 6, 2015
    Messages:
    5
    Likes Received:
    0
    My camera is not transmitting to my android phone or iPad. Says connection lost. I have replaced the WiFi module and have preformed binding to the range extender. Still the same message. When I replaced the module, I found the module in the bird had a dent in it, from a bad crash. However, the camera worked on a flight last fall after the crash. It wasn't until I was getting ready for a beach trip a few weeks ago that I found it not working. No flights from the last good one until it was found to be not working. When I started getting the bird ready for the trip, I charged the batteries, and range extender. In haste to get everything charged, I accidentally plugged a USB cable cable into the camera connected to AC power. Don't know if this could be the issue. This could be something simple I'm overlooking or a big problem. Obviously, the module wasn't the issue, and I don't mind having a spare. Don't want to put a lot more money in this Phantom 2. Any ideas will be greatly appreciated. Attached is a picture of the modules and why I thought that was my issue.[file]wifi module|none[/file]
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Whats the error you are getting? Connection Broken? If so, it could simply be the 3 cables to gimbal. Recheck them and make sure the pins are all straight and sitting firmly.
     
  3. Jackets1955

    Joined:
    Jun 2, 2016
    Messages:
    2
    Likes Received:
    0
    Thanks, that is my plan for tonight. Open her up and recheck cables. Yes, Connection Broken.
     
  4. dgravitt

    Joined:
    Mar 6, 2015
    Messages:
    5
    Likes Received:
    0
    Checked all connects at Camera base and on WIFI Module, all OK. I did notice a small red light on the bottom of the bird on the left at back. Should that be burning? I'm assuming plugging the 110 power in the data port maybe have hosed something. The Camera LED burning amber all the time.
     
  5. Jackets1955

    Joined:
    Jun 2, 2016
    Messages:
    2
    Likes Received:
    0
    Finally found my loose connection, all is well.
     
  6. Ranger690

    Joined:
    May 27, 2016
    Messages:
    10
    Likes Received:
    3
    Location:
    Richmond, VA
    Which connection was it? Was it obvious that it was loose?
     
  7. dgravitt

    Joined:
    Mar 6, 2015
    Messages:
    5
    Likes Received:
    0
    Really not sure. After the advise above, I disconnected and reconnected every cable I could find. Under the hood, and on the camera/gimbal.
     
  8. Ranger690

    Joined:
    May 27, 2016
    Messages:
    10
    Likes Received:
    3
    Location:
    Richmond, VA
    Glad its working for you. I had to buy and install a new wifi module. But it sure is nice to have FPV back. Love playing with this toy.
     
  9. Denis_app

    Joined:
    Jun 27, 2016
    Messages:
    1
    Likes Received:
    0
    Can I change the camera and gimbal from DJ Phantom 2 Vision + to DJI Zenmuse H3-3D Gimbal (for exemple) or other gimbal, no matter???
     
  10. Ic3man

    Joined:
    Jun 2, 2016
    Messages:
    13
    Likes Received:
    0
  11. Bob Aversano

    Joined:
    Aug 15, 2016
    Messages:
    1
    Likes Received:
    0
    I have the same problem. It started when i upgraded to the latest version of the software. Everything works, i can take a picture/video, move camera and operate the phantom but no FPV on the ipad/smartphone. I have tried everything I can think of, going to look at the cables tonight.. Any ideas???