Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera not displaying any image or live video

Discussion in 'Phantom 2 Vision Discussion' started by Selectah_Eric, Jul 25, 2015.

  1. Selectah_Eric

    Joined:
    Jun 3, 2015
    Messages:
    15
    Likes Received:
    1
    So for some strange reason the camera from the Vision 2 i got does not display any sort of video or image when connected however am able to see my gps,range extender and wifi icons also the calculations of the altitude,distance etc... but i can record manually from the camera it self but no display on my andriod nor iphone device :/ any help
     
  2. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,688
    Likes Received:
    5,714
    Location:
    Amory Mississippi
    With the battery out be sure the plug in your camera is pushed all the way in . Also look here and in P2V Help as there's bunch's
    of threads with this issue and maybe ya can see something there that might help ya :)
     
  3. Selectah_Eric

    Joined:
    Jun 3, 2015
    Messages:
    15
    Likes Received:
    1
    Tried and no luck...Idk if theres a fault with the camera
     
  4. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    This just happened to me today too and for what I'm reading it is a common problem. I wish someone had a fix for it.
     
  5. MDR

    MDR

    Joined:
    May 26, 2015
    Messages:
    133
    Likes Received:
    77
    Use a QR code scanner, and rescan the label on the box or bird, then power cycle. You may have to do it several times to get it to take.
     
    dirkclod likes this.
  6. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    Did all that re-binding didn't work re flashed firmware didn't work re-installed app didn't work tried older firmware for the camera and it didn't work. The telemetry works the camera takes video and pictures it just won't display in on the app
     
  7. MDR

    MDR

    Joined:
    May 26, 2015
    Messages:
    133
    Likes Received:
    77
    Ok, have you reset the wifi repeater ?
     
    dirkclod likes this.
  8. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    Yes it was part of the re-binding but a funny thing happened the first time I re - flashed the camera firmware..it worked for a few seconds but then it was gone again
     
  9. MDR

    MDR

    Joined:
    May 26, 2015
    Messages:
    133
    Likes Received:
    77
    I have also had to hard reset the bird before. I have had to do the things mentioned, plus all the things you have tried. Frustrating and nonsensical, but always eventually works.
     
    dirkclod likes this.
  10. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    Do you happen to have a "how to" on the hard reset?
     
  11. MDR

    MDR

    Joined:
    May 26, 2015
    Messages:
    133
    Likes Received:
    77
    I have not discovered a reset pattern. But take a pen, and press and hold the recessed reset button on the bottom of the bird. It is a lit LED, yours may or may not be lit. I know this is not a lot of help, but all things mentioned has always re set that signal. Just do not forget to power cycle after each sequence.
     
    dirkclod likes this.
  12. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    Ok thank you I'm going to try
     
  13. MDR

    MDR

    Joined:
    May 26, 2015
    Messages:
    133
    Likes Received:
    77
    Good luck, it does seem to be a common problem.
     
  14. Propking

    Joined:
    Feb 1, 2015
    Messages:
    38
    Likes Received:
    5
    Location:
    Louisiana
    Had the same issue and done everything possible. Called drone geeks and DJI support and both said it sounded like the video transmitter in the camera. I bit the bullet and found a new camera on eBay and now it works like a charm. It's cheaper than sending your P2V off for repair.
     
  15. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    I think it might be the same for me because yesterday it worked up until I had to change batteries.. I'm so freaking stressed over this I bought me a 3DR Solo just to show DJI how pissed I am... Lol
     
    #15 Rueben, Jul 28, 2015
    Last edited: Aug 14, 2015
  16. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    I still need to get my P2V fixed
     
  17. nativecolorado

    Joined:
    Jan 16, 2014
    Messages:
    14
    Likes Received:
    0
    I've got the same problem with my P2V. First time turning the bird on in a while, I flashed the firmware to get it up to date and I lost video from my camera. I get altitude and GPS on my iPhone display, I can control the camera (tilt), I can take photos and videos, and I can transfer freshly captured photos and videos to my iPhone. I just no longer get the live video stream to see what I'm pointing the camera at. Just a black screen.

    I've done the re-binding numerous times. Swapped out batteries. Power cycled everything numerous (more than dozen) times. Tried older apps on my iPhone. Tried other phones. Every time, the same scenario. Data is flowing, but no live video feed.

    Anyone know what's happening with this?
     
  18. Rueben

    Joined:
    Jul 14, 2015
    Messages:
    61
    Likes Received:
    29
    How can this be happening to so many flyers and there is no fix for it? Well.... I say that and the fix is to replace the camera because the WiFi module is inside the camera on the P2V . I've tested the WiFi extender and replaced the 2 wires of the camera and nothing. I emailed DJI 4 weeks ago and still nothing from those jokers. I'm going to have to bite the bullet and buy a camera in order to get my UAV going.
     
  19. Squiddley

    Joined:
    Dec 29, 2014
    Messages:
    650
    Likes Received:
    244
    Location:
    Yorkton Sask Canada
    I did a hard reset to my bird once you have to open up the bird then jum 2 pins together for a few seconds and the power cycle the bird will see if I can find the youtube video on it, found it if all else fails give this a whirl