Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera issues

Discussion in 'Phantom 2 Vision + Help' started by Hvydg, Aug 1, 2015.

  1. Hvydg

    Joined:
    Jul 11, 2015
    Messages:
    28
    Likes Received:
    2
    Trying to get a camera going on my pv2+. I got this thing used. Installed a new ribbon cable and found out the main board up top was bad. Just got another board and now the LEDs blink red and there is a binding noise. I took it back apart and hooked up just the main gimbal board and motor. When you power the bird on the top motor will just spin wide open. While it is spinning if I connect the ribbon cable back up for the rest of the camera the top motor stops spinning and acts like it's in a bind. Any ideas what the issue might be?
     
  2. Hvydg

    Joined:
    Jul 11, 2015
    Messages:
    28
    Likes Received:
    2
    Forgot to mention. When it's all together and I'm on the vision app it says remove the gimbal lock but the gimbal lock is not on there.
     
  3. wing nut

    Joined:
    Jul 27, 2015
    Messages:
    5
    Likes Received:
    0
    I have the same problem as you Hvydg so I await with interest to see how you get on!
     
  4. Hvydg

    Joined:
    Jul 11, 2015
    Messages:
    28
    Likes Received:
    2
    Well I actually fooled with the ribbon cable connection behind the camera itself. It helped a lot. Everything would work right except the camera. It would turn up then just fall down. I actually got a great deal on a phantom 3 professional on eBay. It had been crashed and the camera separated. Probably will be in the same boat but I couldn't pass it up for $500. Lol.
     
  5. Monkeyleg

    Joined:
    May 13, 2015
    Messages:
    305
    Likes Received:
    27
    Is the main board you put in new? I've only been working on gimbals for a short time, but I've seen a couple where the camera would go into straight-ahead horizontal as it should, then turn down. On one I tried a different main board I knew to be good, and that solved the problem. On another, I tried replacing the pitch motor and it worked. On yet another, I replaced the pitch motor board and it worked.

    I'm looking for a good used main board now because a gimbal holds the camera straight ahead and looking down 45 degrees. The tilt works, but it won't stay horizontal. Always goes to 45 degrees down.
     
  6. Hvydg

    Joined:
    Jul 11, 2015
    Messages:
    28
    Likes Received:
    2
    I bought the main board used. It was suppose to be good but you know how that goes. I did notice the led in front was blinking red and the one in the rear is blinking green. I have another main board with the motor but it won't power on.