Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera / gimbal problem

Discussion in 'Phantom 2 Vision + Discussion' started by andrew, Jul 5, 2014.

  1. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Actually, the camera is fine but the gimbal is not leveling the camera to a nice horizontal position even though the Phantom is nice and level. I've updated the firmware, I've done an advanced calibration, but still having problems. The gimbal arms are not bent, I haven't hit anything (well, I did a while ago but the gimbal and camera worked perfectly after that) and I catch by hand so landings aren't an issue.

    It's almost as though the gimbal is out of alignment, but I have no idea how to 'reset it'? Thoughts?
     
  2. Sasquatch

    Joined:
    Jun 7, 2014
    Messages:
    242
    Likes Received:
    0
    Location:
    Ontario, Canada
    Sorry I'm new still myself but, is the FPV feature turned off in your camera settings?
     
  3. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Yes, the FPV is turned off. Does it make a difference whether it's on or off when the copter is straight and level?
     
  4. Sasquatch

    Joined:
    Jun 7, 2014
    Messages:
    242
    Likes Received:
    0
    Location:
    Ontario, Canada
    Ok then. I don't think so but I"m not sure. However, if you have FPV turned off and are still having issues with the gimbal/camera, then it must be something else.

    Sorry I can't help anymore.
     
  5. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Any guesses as to whether this is mechanical or perhaps software related?
     
  6. The English Guy

    Joined:
    May 14, 2014
    Messages:
    81
    Likes Received:
    0
    If you spend the time to read all the posts for the P2Vplus you would see that you've got one of the standard problems that a lot of people have. We have been hoping that DJI would address the issue almost since the day they released the P2Vplus. But no such luck.
     
  7. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Thanks for assuming I haven't at least tried to go through the forums. Appreciate your info nonetheless.
     
  8. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
  9. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
  10. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    I did the fix again and it seems to be holding this time around...
     
  11. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Hard to believe that shaft is just press-fit with no set screw.