Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Ibmftw

    Joined:
    Apr 1, 2016
    Messages:
    203
    Likes Received:
    82
    Hey all I rigged up a dbs02 which works great, but once I add amps (3 watt sunhans gold) I get problems range is unstable and reduced. It seems I was loosing video link first so I tried swapping amps to make sure one wasent faulty but same problem, I then tried running Radio link amped and video link un-amped at the same time, and same problem. I'm on Litchi at 4mbps. It seems as soon as a single amp is on and transmitting it's skewing both signals is anyone else seeing these problems perhaps these amps are a little overpowered in such close vicinity to the rc and they are picking up and transmitting chatter or causing cross talk. It also seems like I cannot set a channel in litchi no more seems to just revert to what it ever chan it chooses as if in auto.
    Does anyone have a successful amped up dbs02 mod on the gl300c using sunhans 3w golds?
    The sunhans have a max input of 20dbm the gl300c sticks out 17dbm in CE mode (I am in england) so I can't see me needing an attenuator.

    Do you think the sunhans 3w are over powering the dbs02?

    I was testing in a highly populated area, do you think I was picking up too much interference pre-amp?

    I had the amps stuck to the control surface perhaps this was the problem?

    Any input would be appreciated thanks.
     
  2. solsystem

    Joined:
    Aug 30, 2015
    Messages:
    74
    Likes Received:
    15
    From what I've heard amping the DBS antenna is not a good idea compared to amping the right and left polarized antennas. There is more attenuation of signals when using left and right polarization, which results in less interference. Whether your using a 3 watt or 4 watt amp doesn't make too much difference because the controller is not able to drive the amp up to its full capacity. As I understand it, the amps will only put out 600 mili watts approximately.
     
  3. JakeMaxxUAV

    Approved Vendor

    Joined:
    Feb 28, 2015
    Messages:
    654
    Likes Received:
    371
    That rumor was started by a competitor to the ItElite and it's simply not true. My personal results with the P4:
    ItElite: 9000ft
    ItElite + Boosters: 18,000 feet (still had good signal, turned around due to battery concerns)
     
  4. JakeMaxxUAV

    Approved Vendor

    Joined:
    Feb 28, 2015
    Messages:
    654
    Likes Received:
    371
    Have you tried manually setting the Channel? A customer of mine had issues with the screen going black, even at close range, and once he chose a manual channel the problem went away. Also, have you tried flying in that are without the amps?
     
  5. Ibmftw

    Joined:
    Apr 1, 2016
    Messages:
    203
    Likes Received:
    82
    @JakeMaxxUAV basically I am getting poorer range with the amps than without. Perhaps I am getting some manual channel conflicting between apps? I have only done test in a very noisy environment so this could have something to do with it, also I'm waiting on one of your amp mounts so my wiring is currently a little messy, the UFL SMA cables arent routed great etc I'll try do a test tomorrow in a clean environment.
     
    #5 Ibmftw, Apr 15, 2016
    Last edited: Apr 19, 2016