Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Blade not spinning

Discussion in 'Phantom 2 Help' started by cudders, Dec 13, 2013.

  1. cudders

    Joined:
    Dec 13, 2013
    Messages:
    1
    Likes Received:
    0
    One of the blades on my Phantom 2 isn't spinning. I just got the Phantom 2 today, and I have not yet taken it for a flight. I had no trouble calibrating it, and the blades were all spinning after I initially set it up. When I attempted to make my first flight, three of the blades worked, but one did not. Has anyone else had this problem? Any thoughts on what the problem could be?
     
  2. kenskid

    Joined:
    Aug 3, 2013
    Messages:
    146
    Likes Received:
    1
    I've never had that happen. Could be so many things. The motor itself, wiring, bad ESC.
    If it is brand new, I'd surely put in a call to the retailer.


     
  3. phantomflyer

    Joined:
    Nov 18, 2013
    Messages:
    244
    Likes Received:
    0
    Location:
    New Hampshire
    I would go into the assistant software and make sure you have it on the right Mixer type! My guess is if all the motors work in your motor test then maybe your not on the right Mixer setting which should be "Quad-rotor X" Second pick in on Basic, Aircraft where you go to do your motor test!! Or maybe you should test them again could be a loss wire inside.
     
  4. jthorstad

    Joined:
    Nov 24, 2013
    Messages:
    84
    Likes Received:
    0
    Can you spin that prop freely with your finger? Or is it different than the others?