Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Black Pearl problems

Discussion in 'Phantom 2 Vision Help' started by Krimzon_Wolf, May 24, 2015.

  1. Krimzon_Wolf

    Joined:
    Jul 11, 2014
    Messages:
    15
    Likes Received:
    0
    Hey guys,

    Its been a while since I posted anything, but I got my phantom 2 almost a year ago and everything has performed flawlessly. I have been using a Black Pearl FPV to monitor the video along side the AVL 58 as the reciever and haven't had any problems...until now.

    We wanted to see if we could hook our Black Pearl to one of our 5D mk III's as an external monitoring system via HDMI cable. It worked and so on our next video gig we hooked it up to one of our cameras and it worked great. Then last night we tried changing the mode so that the monitor would work with our phantom 2 for a quick drone shot of the wedding venue. We changed the mode to "DIV" which I'm assuming is the mode that we used during previous flights as we were receiving something on the monitor, but it was so distorted that it was impossible to tell exactly where the camera was pointing. We then tried changing channels, modes, and everything that we thought could be changed with no success.

    I did some research to see if anyone else had the problem and I couldn't find anything that applied to us.

    Thanks
     
  2. noiseboy72

    Joined:
    Jul 13, 2014
    Messages:
    575
    Likes Received:
    17
    Location:
    Lincs, UK
    Probably PAL / NTSC changed?