Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

BC20-4 Balance Charger Flashing Lights - Is this normal?

Discussion in 'Phantom 1 Help' started by HurricaneProductions, Aug 2, 2013.

  1. HurricaneProductions

    Joined:
    Apr 30, 2013
    Messages:
    14
    Likes Received:
    0
    Hello everyone, thanks in advance for the help.

    I'm getting solid red - flashing red alternating; see the attached video. I've had the phantom for nearly 6 months and I've never seen the charger blink like this. And it happens with both of my batteries. Any advice would be greatly appreciated.

    [youtube]http://www.youtube.com/watch?v=fuR723vJkxk[/youtube]

    Thank you.

    Hurricane
     
  2. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    One of my chargers just started doing the same thing.

    Did you learn anything about "WHY"?
    Thanks
     
  3. JH_PiNoY

    Joined:
    Jun 23, 2015
    Messages:
    25
    Likes Received:
    1
    Looks like one of your cells on your lipo is no good. I have that problem too. The only reason I found out is because I had another balance charger that I used. Once the lipo 3s battery was supposedly fully charged, and put load into it as in fly it with my quad. It would only last me 1 minute flight. Right after the quick flight i checked my cells individually and my middle cell voltage was extremely low but my 1 and 3 cells were still good.
     
    #3 JH_PiNoY, Jun 25, 2015
    Last edited: Jun 25, 2015
  4. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    Welcome to the party JH.
    You will find some helpful links in my signature.



    The battery is a 9 month old MultiStar 4000 10C in fairly good condition, just like the other 3 I have.
    I have a voltage checker that checks each cell and they are all good.
    Right now the battery is at 11.6 volts. cell 1= 3.85, 2= 3.88, 3= 3.87
    That is about where it was 12 days ago.

    I had just flown with the battery, a few hours earlier and it performed normally.
    Thanks for taking a stab at it though.