Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery won't charge

Discussion in 'General Discussion' started by MarkRx, Mar 9, 2014.

  1. MarkRx

    Joined:
    Mar 9, 2014
    Messages:
    6
    Likes Received:
    0
    Hey everyone,

    Im new to the community and bought a phantom 2 non-vision last week. I had a few chances to fly it the past couple days and I'm now down to roughly 30% battery life. When I plug the battery in to the charger nothing happens. I really only have about 20 min of flight time on it. The green light on the chargeris lit up, but when I go to plug the battery in nothing seems to happen. No lights or anything. Do I have to wear the battery completely down before it accepts a charge? Anything I can do in the assistant software? The place I bought it from has a full 30 day refund policy, but it would suck to repack everything just because of a battery issue.

    Thanks for any help!

    Mark
     
  2. mikeydaddio

    Joined:
    Feb 4, 2014
    Messages:
    166
    Likes Received:
    0
    No! Don't drain it any more: draining a Lipo all the way just once will ruin it. Do you have a voltmeter where you can test each cell off the balancing port? Just test voltage between the 1st and 2nd pin, 2nd and 3rd, and 3rd and 4th and see what you get for each cell.

    Mike
     
  3. ratbastard

    Joined:
    Jan 19, 2014
    Messages:
    5
    Likes Received:
    0
    Location:
    Earth
    I have a similar problem. My P2V arrived on the 5th. I received a 2nd battery as part of the purchase. I charged both batteries that night. Both started with 2 green lights, then once fully charged all lights turned off.

    I used the battery that came with the P2V for the last couple of days. Each time I recharged the battery, it would fully charge and the lights would turn off.

    Today, I tried to charge the original battery and no lights would come on. The charger has a green light. When I press the button, all four green light flash.

    The second battery seems to work fine.