Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery Warning notice

Discussion in 'Phantom 2 Vision Discussion' started by milezone, Jan 7, 2014.

  1. milezone

    Joined:
    Dec 29, 2013
    Messages:
    58
    Likes Received:
    0
    Hi All,

    So just took my first flight today. 3 minutes into flying I get a 20% battery warning! although it is fresh charged and shows 89% on Apple app.
    Did this twice to me, both times I hit ignore.

    But I thought the firmware updates fixed this problem, as I pretty sure I did this correctly for quad and remote. Is there something I am missing?

    Milezone
     
  2. milezone

    Joined:
    Dec 29, 2013
    Messages:
    58
    Likes Received:
    0
    Ok I did a firmware update again just to make sure, and took a screenshot to see if you guys think I did things correctly.

    [​IMG]
     
  3. iDrone

    Joined:
    Nov 14, 2013
    Messages:
    612
    Likes Received:
    2
    Location:
    Los Angeles, California USA
    Looks good. Did you get a "Low Battery" warning or "invalid battery" warning? These sound similar but are caused by distinctly different things. If you got a "Low Battery" warning, see if the following thread sounds like what you experienced:
    http://www.phantompilots.com/viewtopic.php?f=7&t=4710

    iDrone
     
  4. YeeaaBoii

    Joined:
    Jan 5, 2014
    Messages:
    145
    Likes Received:
    7
    Location:
    Athens, TX
    I've been getting a strange battery warning since I updated too. After I updated, I changed the first level warning to go off at 20% and the second level I left at 15%. The low battery warning goes off for me randomly about every 30 seconds when my battery approaches 30%. Today it started random alarms at 32%, yesterday it started at 40%. It does that until it gets to 20%, then it goes off constantly like I set it up to do in the assistant program. I also had a strange loss of power upon hitting 20% where my Phantom could not gain altitude when I applied full throttle. I made a safe landing thankfully, cycled the motors, and it took off again with full power as if it had a full battery. I ran it down to about 15% before bringing it in. I talked to DJI about it and they recommended I reinstall the update and not mess with the stock settings but he did mention they had been getting calls lately about weird battery alarms so I think it may be a bug in the update.