Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Battery Issues?

Discussion in 'Phantom 3 Help' started by sbarso, Oct 4, 2015.

  1. sbarso

    Joined:
    May 21, 2015
    Messages:
    15
    Likes Received:
    0
    Hi All,

    I am having some issues with my phantom3P.

    The battery is full the app says ready to fly but the phantom constantly beeps and there is no battery information available in the app. I have 3 batteries and they all do the same thing.

    I did have a small crash the other day. Hit some tree branches and the quad fell about 0.5m to the ground. There was no apparent damage and I have flown it a couple of times since with no problems.

    When I turned it on today it was initially making the beeping sound like it was doing a firmware update, although unless there has been one in the last few days it should have been up to date. Believing it had a fault I turned it off and on again and that is when the constant beeping started.

    Any ideas on how I may be able to fix it.

    Thanks in advance.

    Steve.
     
  2. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    What firm ware are you running on the Controller and the Phantom?
     
  3. sbarso

    Joined:
    May 21, 2015
    Messages:
    15
    Likes Received:
    0
    Hi Bob,

    Thanks for the reply. I believe everything is up to date. Phantom is 1.03.0020. Not sure about the controller but it has been working fine since the last update.
     
  4. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    So you have not upgraded to 1.4.1 on the Phantom?

    Have you flow the P3 with the present batteries on this firmware.

    when you upgraded, did you delete the bin file from the SD card when the upgrade completed?
     
  5. sbarso

    Joined:
    May 21, 2015
    Messages:
    15
    Likes Received:
    0
    You may have pinpointed my problem. Yes I did update to 1.4.1 on the Phantom but I put a different sd card in that still had the 1.03.0020 firmware on it. It must have been reading that when I interrupted it by turning it off.

    Can I fix it by putting the sd card with the correct firmware on it or have I caused bigger issues.
     
  6. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Try this first. Take the bin files off the SD card-- and Try to boot up with a blank card and see what happens. Maybe it did not revert back.

    If that wont work, put the 1.4.1 back in and power the Phantom-- it will probably start beeping or screaming. Check the led on the front of the gimbal mount, it should show red and green blinking if it is updating to 1.4.1 again. If it is making to much noise , stick it in the closet until it finishes. After the update, if it works, reformat the SD card to get the bin file deleted.

    Check back and let me know how you did.

    Cheers:)
     
  7. sbarso

    Joined:
    May 21, 2015
    Messages:
    15
    Likes Received:
    0
    Hi Bob,

    The first idea didn't seem to work. As you suggested I have locked it in the cupboard with a sd card with the 1.4.1 firmware on it. It is making a horrible constant "BEEP,BEEP,BEEP" not the normal "almost tolerable" update beep beep. I will leave it going for a while and see what happens.

    Thanks again for your help.

    Steve
     
  8. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Give it at least 30 minutes-- hope it works out. Cheers:)
     
  9. sbarso

    Joined:
    May 21, 2015
    Messages:
    15
    Likes Received:
    0
    Thanks Bob, it took a while but that seemed to fix it. Blowing a gale here now so too windy to fly but everything looks good.

    Thanks again.