Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery Gauge Stuck at 71%

Discussion in 'Phantom 2 Vision Discussion' started by grochester, Mar 10, 2014.

  1. grochester

    Joined:
    Dec 29, 2013
    Messages:
    114
    Likes Received:
    0
    Location:
    Canada
    On my last flight the battery gauge stuck at 71%. I checked it a few times while the P2V was in the air as it seemed like I was getting an exceptionally long flight. Then realized it was not counting down. So I flew back home and just as I got it back close to me it went into self landing mode. I landed, turned the P2V off and left the app running. Turned the P2V on again, connected the network and got a battery reading of 28%. Haven't had a chance to fly since then to see if it will happen again. Anyone had a similar incident? Any thoughts on cause?
     
  2. jdmutton

    Joined:
    Jan 8, 2014
    Messages:
    30
    Likes Received:
    0
    Haven't had that issue but I think step 1 would to be fly it again on a full recharge and see it the same occurs again keeping in mind your time in the air to offset any unforeseen problem. Pending the problem remaining try a delete and reinstall of the vision app and do a re fly.
    If all else fails after that try a rebind of the phantom fc200 camera with the range extender. You'll need the original packaging as this has the QR code relevant to your unit on the side of the box. Follow the rebinding procedure as per the DJI instructions....lots of luck!
     
  3. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    I occasionally get video or telemetry freezes on my android app. If you either back out to the main menu and back in to camera view or just quit and restart the whole app then that normally clears it.

    If you suspect it's less an app glitch and more a battery issue then plug in to the Vision Assistant and see what the battery stats are looking like.
     
  4. Stealthdude

    Joined:
    Dec 20, 2013
    Messages:
    50
    Likes Received:
    0
    I've had no battery reading on my app before and also a message saying there is no SD card installed. On both occaisions restarting the phone worked, I.e. power down and restart the phone. I'm guessing it's a bug in the app with my phone.