Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery firmware???

Discussion in 'Pro/Adv Discussion' started by Karatekid1800, Jul 22, 2016.

  1. Karatekid1800

    Joined:
    Nov 26, 2015
    Messages:
    39
    Likes Received:
    2
    Hi guys, I have a quick question. I have an old p3 battery that was updated to my old p3p (firmware 1.8.60). I have a new p3p with an older firmware 1.4.1+ , will this cause a problem assuming that I don't want to upgrade the new drone?
     
  2. MikeyOnline

    Joined:
    Apr 22, 2016
    Messages:
    338
    Likes Received:
    116
    AFAIK, it won't cause problems. If it does, the software will just require you to update and refuse to fly on that battery. I upgraded to 1.9.60 and then downgraded to 1.8.80 but the batteries won't downgrade. So I'm flying on 1.8.80 with 1.9.60 battery FW with no problems. I think the battery FW is exclusive to just the battery and it doesn't "interact" with the AC FW. Someone correct me if I'm wrong.

    Mike
     
  3. Karatekid1800

    Joined:
    Nov 26, 2015
    Messages:
    39
    Likes Received:
    2
    It sounds reasonable, thanks for the response. Any other opinions?
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,890
    Likes Received:
    5,564
    Location:
    US
    You can use your updated battery on your new P3P. As for your Phantom, DJI GO will prompt you to install the firmware update. You can certainly ignore that prompt though.