Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery Errors keep popping up!

Discussion in 'Phantom 2 Vision Help' started by Okie72, Nov 15, 2014.

  1. Okie72

    Joined:
    Nov 15, 2014
    Messages:
    39
    Likes Received:
    14
    I just purchased a new phantom 2 vision and after charging all the batteries and installing the vision app, I turned on everything to test the wifi and the vision app to see how the camera works and just setting it on my table and looking at the vision app it keeps popping up theses battery alarms. The pictures shows what the alarm looks like. I have two new batteries and both of them do the same thing. And this is just powered up with no motors running, I have never even started the motors up yet. Kinda afraid too seeing all these alarms. Help Please!
     

    Attached Files:

  2. Uptowndisco2

    Joined:
    Oct 18, 2014
    Messages:
    60
    Likes Received:
    9
    If you are using the vision app to view the camera feed it will over heat without the cooling effect of the props in flight.
     
  3. Happyflyer

    Joined:
    May 5, 2014
    Messages:
    1,805
    Likes Received:
    98
    Location:
    Cold, Cold, Michigan
    Well, that is a new one on me. Never heard of such a thing. If so, mine would have burned up a long time ago.
     
  4. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    16
    He is showing battery errors..... Do the batteries feel warm to the touch? Or is it just another false error. You can try updating the batteries and see if that takes care of it. Warning on doing this is some batteries become bricked by updating.
     
  5. Okie72

    Joined:
    Nov 15, 2014
    Messages:
    39
    Likes Received:
    14
    I powered off everything after seeing these pop up for a while and pulled the battery and it's not even warm. One of the alarms showed that the discharge temperature was low, which doesn't make any since to me!
     
  6. Happyflyer

    Joined:
    May 5, 2014
    Messages:
    1,805
    Likes Received:
    98
    Location:
    Cold, Cold, Michigan
    Have you done all the possible updates? Even though it is new, take a look at the battery contacts on the quad. Especially the small round or square ones on the battery to be sure they are clean. This is not an actual heat up problem. I have had mine on in the past checking "things" for so long the controller put out the "beep" telling me it has been at idle too long and never got a "hot" battery warning.
     
  7. Okie72

    Joined:
    Nov 15, 2014
    Messages:
    39
    Likes Received:
    14
    I called B & H Photo, that's where I purchased it at and they told me to install the latest updates on it. After going through all of that and everything seem to be current, I started everything back up and now on the vision app I get all the data from the phantom except can't get live camera feed. It's like the phone is trying to update but never seems to finish. You are supposed to get live camera feed while it's on the ground right.
     
  8. iswimmer

    Joined:
    May 7, 2014
    Messages:
    28
    Likes Received:
    0
    Also try completely closing the app and restarting it. That always works for me.
     
  9. Okie72

    Joined:
    Nov 15, 2014
    Messages:
    39
    Likes Received:
    14
    Thanks everyone, I believe all the issue's have been resolved for now!