Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Barometric sensor problem?

Discussion in 'Phantom 1 Help' started by bumper, Sep 8, 2013.

  1. bumper

    Joined:
    Aug 6, 2013
    Messages:
    94
    Likes Received:
    0
    Crashed yesterday, pilot error, hit roof overhang and fell 12 feet to ground, landed upright, no visible damage. Nothing loose inside. Did advanced IMU calibration as well as compass (both several times). Calibration shows good, all indictor lights good. Other than in-flight behavior, all else seems normal.

    In hover, Phantom will sometimes stay in place for several seconds, then accelerate up rapidly as much as 20 - 50 feet, then descent back down just as rapidly (with me adding throttle to save it!). This occurs in GPS Atti, and Atti, not skilled enough to try manual but I bet that would work (grin).

    My understanding is the baro sensor is used for maintaining altitude and sensing climbs and descents, so I'm assuming this got damaged in the crash? If the fix to replace the NAZA? Anyone else experience this? How was it resolved?

    Oh, also tried rapping the shell hard with fingers and then doing another advanced cal - - - no change.

    Help please . . .

    bumper
     
  2. bumper

    Joined:
    Aug 6, 2013
    Messages:
    94
    Likes Received:
    0
    Update:

    Took Phantom apart, removed NAZA and took that apart, checked GPS antenna for cracks (though that would not have caused the symptoms I got). Reassembled and now it works fine. Did a bunch of flights without FPV and camera as I build confidence it will work and not do a fly-away.

    Guess I may never know what the problem was . . .oh well, up - up - and - away!


    bumper