Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

balance issue when FC40 camera is mounted

Discussion in 'Phantom FC40 Discussion' started by dormaj, Jul 28, 2014.

  1. dormaj

    Joined:
    Jul 28, 2014
    Messages:
    7
    Likes Received:
    0
    I tried to fly the FC40 for the first time with the camera attached and it just nosed forward into the ground on attempted take off. So I removed the camera and mount and had a wonderful first flight. Is there a trick to setting the prop speed to adjust for the extra weight when the FC40 camera is mounted? Should Naza-M take care of that?

    Thanks in advance!
     
  2. wattage

    Joined:
    Jul 13, 2014
    Messages:
    264
    Likes Received:
    2
    Location:
    Scotland, UK
    Were you in full throttle at takeoff? Commit to the takeoff and don't get cold feet as it's lifting off or the FC40 will just go into lawnmower mode.
     
  3. dormaj

    Joined:
    Jul 28, 2014
    Messages:
    7
    Likes Received:
    0
    Lawnmower mode. Very well said. I'll give full throttle a try!

    Thanks!
     
  4. J.James

    Joined:
    Apr 21, 2014
    Messages:
    1,882
    Likes Received:
    162
    Location:
    Upstate NY
    Also if its starting to tilt at all why you are hitting the throttle full force. You can also correct some by also using a tiny bit of right stick to counter it. Which works good to if you are takeing off on unlevel ground.

    But when taking off like wattage said don't get cold feet at all... actually don't be timid at or out or be gental at all and just put the left stick up hard and fast till its off the ground.