Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Bad range on fpv.

Discussion in 'FPV (First Person View)' started by OEKA, Feb 12, 2015.

  1. OEKA

    Joined:
    Nov 23, 2014
    Messages:
    57
    Likes Received:
    1
    Hi.

    Out flying today, first day with good weather and HJ450 rebuild done. Was exited to test fpv range from quad to transmitter, somewhat disappointed now :/
    After about 160meters (524ft) i lost the signal.
    This is my transmitter gear:
    TX&RX: http://ebay.to/1yt0xsa
    Antenna TX: http://bit.ly/1AtjKzp
    Antenna RX: http://ebay.to/1KPPFNw

    The antenna is placed like this, left side poiting down.
    [​IMG]

    Any thought on placement or gear?

    Cheers
     
  2. dptcalvin

    Joined:
    Nov 29, 2014
    Messages:
    715
    Likes Received:
    12
    I would blame it on the cheap antennas.

    I'd also recommend extending the vTx antenna lower to prevent obstruction.
     
  3. landmannnn

    Joined:
    Jan 18, 2015
    Messages:
    350
    Likes Received:
    62
    Location:
    Coventry and Limoges
    Are both antennas left hand polarised? (or both right hand). Hard to tell from the descriptions. Somebody posted about their cheap mushroom receiver antenna, they took it apart and it was a very poor attempt.
     
  4. OEKA

    Joined:
    Nov 23, 2014
    Messages:
    57
    Likes Received:
    1
    Thanks for the reply.

    Could anybody link me a set of good antennas that i could use with this 2.4g tx/rx? I am always on a budget, but id like to get all the tips i can get!

    Thanks

    Oyvind
     
  5. terrylowe

    Joined:
    Nov 17, 2014
    Messages:
    327
    Likes Received:
    34
    Location:
    Hattiesburg, MS USA
    This is such a popular question that there is sticky on this.
    Here is what I use., but it is 5.8ghz for FPV and 2.4 ghz for the controller for my Phantom 2 (non-vision). For me, this was the best upgrade for my system. A little pricy, but the best.
     
  6. horne47789

    Joined:
    Apr 10, 2014
    Messages:
    49
    Likes Received:
    0
    I have a very similar setup and get aboutb500m range. Be sure the tx and rx are on the same channel, or try changing th channels and retest. That helped me a lot when I got it.

    Damian.