Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Bad camera on p2 vision+

Discussion in 'Phantom 2 Vision + Discussion' started by Mr DroneNut, Feb 10, 2016.

  1. Mr DroneNut

    Joined:
    Jan 8, 2016
    Messages:
    52
    Likes Received:
    12
    I just won a bid on ebay for a p2v+. It has a camera that looks like the one on my p3a, and my oldp3s. I don't have my hands on it yet, but from the photos, and from what the previous owner told me , the light on the camera stays red and no picture is received. The p2v+is only about 6 or 7 months old ,and I was told that the camera never has worked. Any idess??
     
  2. Craig.W

    Joined:
    Jan 19, 2016
    Messages:
    48
    Likes Received:
    1
    The camera prolly has a bad firmware on it or corrupted firmware files


    Sent from my iPhone using PhantomPilots mobile app
     
  3. Craig.W

    Joined:
    Jan 19, 2016
    Messages:
    48
    Likes Received:
    1
    Someone prolly installed the wrong Camrea firmware on it so when you do receive it be sure to to format a memory card and place the correct firmware on the root of the memory card and place it in the camera module and install it to the camera and see what happens okay?..

    Oh one more thing problem like these occur when the firmware of the camera isn't installed correctly and they either turn off the drone or eject the camera before the camera could fully finish the update.... Let me know how it goes though when you do get it @Mr DroneNut


    Sent from my iPhone using PhantomPilots mobile app
     
  4. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    from my experience, red solid light means bad gimbal cable, that is if the camera initializes ok and light stays red.
     
  5. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    [QUOTE=" be sure to to format a memory card and place the correct firmware on the root of the memory card [/QUOTE]

    he's talking about the P2V+ gimbal, not P3
     
    dirtybum likes this.
  6. Mr DroneNut

    Joined:
    Jan 8, 2016
    Messages:
    52
    Likes Received:
    12
    Ok. Quick update. Upon receiving the p2v+ I found that the gimble is completely dead. Also there is no data coming from the camera. No battery information. No anything. But the red light is working on the gimble. So that means power is getting to it. I took the cover of to check the connections. All ok. Can someone please tell me the function of each of the 3 cables? There is small, a little larger, then the big one. Thanks
     
  7. Mr DroneNut

    Joined:
    Jan 8, 2016
    Messages:
    52
    Likes Received:
    12
    The camera is dead along with the gimble
     
  8. Mr DroneNut

    Joined:
    Jan 8, 2016
    Messages:
    52
    Likes Received:
    12
    Also. The drone will not communicate with the computer. I've loaded the p2v+ Naza assistant and the correct drivers. My computer talks to all of my other drones, I.e. my p3a my fc40, my Cheerson CX20 and my Walkera Qrx 350pro.
     
  9. Craig.W

    Joined:
    Jan 19, 2016
    Messages:
    48
    Likes Received:
    1
    Mr. Dronenut please to PM


    Sent from my iPhone using PhantomPilots mobile app
     
  10. Craig.W

    Joined:
    Jan 19, 2016
    Messages:
    48
    Likes Received:
    1
    ASAP!.


    Sent from my iPhone using PhantomPilots mobile app
     
  11. Lazermax19

    Joined:
    Feb 13, 2016
    Messages:
    25
    Likes Received:
    1
    Try another cable