Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Autopilot - erratic video behaviour

Discussion in 'Pro/Adv Discussion' started by Erroll, Sep 23, 2015.

  1. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    I have been flying with Autopilot for a while and I am very pleased with its flying abilities. However, the video recording is very erratic. For example, during all my "follow" flights it records 5 or 6 separate pieces of video, roughly 30K - 60k each. In several places it records nothing, and then arbitrarily just starts recording again, so one can't even splice the bits together without having gaps.

    Has anyone else encountered this? What did you do about it?
     
  2. mirrorimage

    Joined:
    Sep 3, 2015
    Messages:
    384
    Likes Received:
    113
    Location:
    Palo Alto, California
    I belive there is a bug with iOS 9 and apps that use the SDK. Are you on iOS 9?
     
  3. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    Nope.
     
  4. autoflightlogic

    Joined:
    Mar 24, 2015
    Messages:
    303
    Likes Received:
    135
    Never seen this happen before. Have you tried using a different memory card?
     
  5. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    No, I haven't, but later in the day I did a 8.2km round trip while using DJI GO, and recorded every second without interruptions, on the same card.
     
  6. Bret Lucas

    Joined:
    Jun 1, 2015
    Messages:
    302
    Likes Received:
    180
    I'm using autopilot with no recording problems at all.
     
  7. sdharris

    Joined:
    May 9, 2013
    Messages:
    450
    Likes Received:
    151
    Location:
    South West, England
    I've not experienced the problem using AFL. Does it happen in a particular mode or all, and does the app give an error at the time or quite happily sit there engaged doing its thing?

    I would perhaps format the card in DJI GO, try that and then a different SD Card if the format does not work.
     
  8. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    I've only experienced it while flying in "Follow" mode.

    I'm back in the city and won't be able to fly long flights for a while. I'm going fishing again in 3 weeks, then I will attempt to establish a pattern, including using different cards/formats.

    Thanks for the interest, folks.
     
  9. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    I have re-installed IOS 8.4.1 because of all the other issues, but I have lost the Autpilot app in the process. How do I re-install it and the in-app purchases without buying them again?
     
  10. ViperNuke

    Joined:
    Dec 24, 2014
    Messages:
    318
    Likes Received:
    103
    The app doesn't give you the option to reinstall all in app purchases?? Mnnnh
     
  11. ViperNuke

    Joined:
    Dec 24, 2014
    Messages:
    318
    Likes Received:
    103
    Also the recording issues you are having with follow me mode had nothing to do with iOS 9... I'm on iOS 9 and been doing follow me mode with the app and no recording issues...
     
  12. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    I need to re-install the app first before I can answer that question.( I am not all that familiar with Apple products and software.)
     
  13. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    Yip, I am aware of that. I experienced those issues before upgrading to IOS 9.
     
    #13 Erroll, Sep 27, 2015
    Last edited: Sep 27, 2015
  14. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    All good. In-app purchases reinstalled.
     
    ViperNuke likes this.
  15. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    I finally had the opportunity to do some more testing and I am happy to report that everything is working as desired.

    Here is a video of one of my runs. (I am travelling a bit slowly because I am on a farm road with speed bumps!)

    The quad is roughly 150' up and about 300' feet behind. The drop from the main road to the river is about 100 meters. I selected altitude via GPS in Autopilot and as can be seen, it follows the drop very closely.

    I am very pleased with this result!.

    PS. Notice the wide sweep out over the river when I turn sharp left.....interesting behaviour?

     
    #15 Erroll, Nov 25, 2015
    Last edited: Nov 25, 2015
  16. sdharris

    Joined:
    May 9, 2013
    Messages:
    450
    Likes Received:
    151
    Location:
    South West, England
    What was the solution to your recording issue?

    Nice video by the way.
     
  17. Erroll

    Joined:
    May 15, 2015
    Messages:
    501
    Likes Received:
    212
    Location:
    South Africa
    Thanks.

    No specific fix. I am up to date with all software and firmware upgrades, including IOS, and I suspect the combination made it all good.

    I did a lot of flying this past week and weekend, long distance (5.3km out) , Airnest's Path, Autopilot's Follow, Waypoints - the lot, in the mist, over water - everything - and I experienced no problems what so ever! I am very pleased today!

    Here's one over water: