Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Attitude Mode Doesn't Work (acts as GPS)

Discussion in 'Phantom 2 Vision Discussion' started by ehcropydoc, Mar 18, 2014.

  1. ehcropydoc

    Joined:
    Feb 21, 2014
    Messages:
    23
    Likes Received:
    0
    Hey peeps,

    I tried searching for this answer and no luck. All is good with my P2V. Been flying for a month now and no crashes, perfect operation, etc.

    My question is about Attitude mode. While flying in Phantom Vision STOCK setup, when I switch from GPS to attitude mode (S1 switch from TOP to Middle, I get nothing. It acts the exact same as GPS. Do I have to enable NAZA mode to get this to work?
     
  2. Big Ben

    Joined:
    Jan 17, 2014
    Messages:
    344
    Likes Received:
    0
    Yes you do.
     
  3. rnrnrn

    Joined:
    Nov 21, 2013
    Messages:
    49
    Likes Received:
    1
    You do have to enable Naza mode and it's really a good idea to do so once you have a bit of experience with the Vision. Do be careful with the options though - GPS mode is fine usually, attitude mode is a good way to practice your control in windy conditions (slight wind at first!!!) but the manual mode if you do set it up is quite difficult and should be avoided at first.

    Once you set up your switch options do be careful which position it is in at take off and later - I can't stress it enough ;-)

    Happy flying in Naza mode :p
     
  4. Mossie

    Joined:
    Feb 10, 2014
    Messages:
    154
    Likes Received:
    1
    Location:
    North Leeds UK
    You can set the lower position of the S1 switch to Failsafe/return home or manual mode when in NAZA, but you have to do this in the Assisitant software.
    I would set to Failsafe/Return home, then there's no chance of accidentally getting into manual mode. Also you can check the return home feature without having to switch the transmitter off.
     
  5. ehcropydoc

    Joined:
    Feb 21, 2014
    Messages:
    23
    Likes Received:
    0
    Thanks guys....this helps me out! I will try NAZA mode this weekend.