Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Assitant software

Discussion in 'Phantom 2 Vision Discussion' started by phantomi, Nov 11, 2014.

  1. phantomi

    Joined:
    Jul 17, 2014
    Messages:
    505
    Likes Received:
    62
    Hi. Please illustrate me. I'm currently with the 3.2 assistant software but had read about a 3.6 update in the dji site. It state that Download the Firmware via Assistant software, but my 3.2 assistant state there is no updates.?? Can I upgrade the main controller to 3.08 and do the battery firmware upgrade thru the 3.2 assistant?
     
  2. IrishSights

    Joined:
    Jan 14, 2014
    Messages:
    1,410
    Likes Received:
    37
    Location:
    Bangor, Northern Ireland, UK
    You need to download the latest assistant 3.6 then it will do the firmware updates. No dont use 3.2 to update the batteries use 3.6 only
     
  3. gunslinger

    gunslinger Moderator
    Staff Member

    Joined:
    Nov 3, 2013
    Messages:
    2,722
    Likes Received:
    497
    Location:
    Least Coast...

    Whoa... I used 3.2 to update my batteries, before 3.6 came out... What's the down side? :eek: :shock:

    Thanks...
    -slinger
     
  4. IrishSights

    Joined:
    Jan 14, 2014
    Messages:
    1,410
    Likes Received:
    37
    Location:
    Bangor, Northern Ireland, UK
    I read here that some bricked their batteries and had to be sent off to dji for a fix. Not sure which version of '3.6' it was with the plethora of patched versions all around the same time all with the same ver no.
     
  5. phantomi

    Joined:
    Jul 17, 2014
    Messages:
    505
    Likes Received:
    62
    Thanks. Do I need to uninstall 3.2 before installing 3.6?
     
  6. IrishSights

    Joined:
    Jan 14, 2014
    Messages:
    1,410
    Likes Received:
    37
    Location:
    Bangor, Northern Ireland, UK
    No just install and run :)
     
  7. phantomi

    Joined:
    Jul 17, 2014
    Messages:
    505
    Likes Received:
    62
    Thanks again. Want to be sure with this 3.08 updating thing.