Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Assistant - No connection

Discussion in 'Phantom 2 Vision Help' started by Timtro, Dec 20, 2013.

  1. Timtro

    Joined:
    Nov 28, 2013
    Messages:
    234
    Likes Received:
    45
    Location:
    Florida
    Got a notice from DJI about updating firmware. OK, so I installed the 1.08 Assistant, turned on the P2V, turned on the controller, connected the USB cable and waited... and waited... and waited.

    The program says "skip", so I clicked that. And waited....

    I tried installing it on a different W7 computer. This one said "failed to install driver". Tried the Assistant again. Same thing: nothing. When I connect the USB instead of the usual "ba-bink" connection sound it just sounds like "bonk".

    Installed 1.08 again on both machines. And waited... and waited...

    No connection.

    What am I doing wrong?

    Windows 7/Pro/64
    P2Vision
    Firmware 1.05
     
  2. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    You need to install the appropriate Windows drivers first, if you haven't already done so. Available to download from the DJI site, just under the Assistant download...
     
  3. Timtro

    Joined:
    Nov 28, 2013
    Messages:
    234
    Likes Received:
    45
    Location:
    Florida
    Thanks for the reply.

    I finally figured it out and ran the driver installer. Successfully completed the update after a bit of guesswork. Good to go now.