Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Are DJI Go versions and hardware FW codependent?

Discussion in 'Pro/Adv Discussion' started by Ataribravo, Apr 2, 2016.

  1. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    I just installed the current version of DJI Go from the DJI website and now I cannot connect to my P3P. I have never updated the FW (still using 1.4.x that it came with). Do I have to update the FW to be compatible with the Go app or are they completely independent? Is any version of the Go app dependent on a specific version of FW? Thanks!
     
  2. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,272
    Likes Received:
    500
    Location:
    U.S./ Canada
    Seems I remember the latest DJI Go won't let you update below 1.5

    Not sure about your exact situation.
     
  3. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    I'm seriously thinking about using Litchi and noticed that you are using it as well. How are you liking it?
     
Loading...
Similar Threads - DJI versions hardware Forum Date
Currently available firmware versions in DJI Assistant Phantom 4 Pro Discussion Friday at 3:06 PM
Matchng DJI Go versions to tutorial Phantom 4 Pro Help Jun 11, 2017
DJi go , Older App Versions blocked Control (Go, Litchi, etc..) Mar 25, 2017
DJIGO app does not give FW versions... another way? Control (Go, Litchi, etc..) Mar 16, 2017
DJI go early versions Pro/Adv Discussion Feb 10, 2017