Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

App disconnects frequently since new firmware update

Discussion in 'Pro/Adv Discussion' started by Jamsta, Mar 25, 2016.

  1. Jamsta

    Joined:
    Jan 18, 2016
    Messages:
    71
    Likes Received:
    8
    I know this has been a problem with others, but I was wondering if anyone is suddenly having this issue since the newest firmware version upgrade? Many times I start everything up and the app just says disconnected. Then suddenly it starts working. I will be flying around and it will disconnect for maybe 30 seconds then connects again. While disconnected I still have control of the aircraft with the RC but nothing on the app. Doesn't do it all the time. I flew out earlier today to 14K' and connected the whole time. Next flight closer and it disconnects constantly. Before it used to launch the app automatically but now most flights it says disconnected at the beginning all the time.

    P3A, Samsung S6, hdmi module. Aftermarket cable but I don't think that is the cause because it was working fine for months prior.

    Any suggestions - thanks.
     
    aerea likes this.
  2. NRJ

    NRJ

    Joined:
    Dec 18, 2015
    Messages:
    596
    Likes Received:
    141
    Hah! You're lucky. I haven't been able to even connect my aircraft with the RC. My update said failed. I tried to do it again, but it just keeps saying update failed. No fix yet.
     
  3. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,151
    Likes Received:
    1,665
    Location:
    San Francisco, CA
    I think you are more lucky as you atlas know the problem.
     
    NRJ likes this.
  4. Adam Papworth

    Joined:
    Jan 31, 2016
    Messages:
    6
    Likes Received:
    2
    Location:
    Perth
    BRAND NEW P3P, using latest version (March 2016) DJIGO App on an iPhone 6, as soon as I took it out of the box and plugged the phone to the RC the RC started making 1990's modem noises which turned out to be it updating, then the app said everything else needed updating, once completed it all seemed to work and connect but upon walking 2 meters away I get the red disconnected notice. I was not confident to try and fly it as I would have to stay within 2 meters to be able to calibrate without it disconnecting (the red disconected on the app and the green light next to the relinking button would turn red) so without propellors I started up the motors and walked over 2 meters from the aircraft, as soon as I did I got the red disconected and the motors stopped.
     
  5. StratocasterDave

    Joined:
    Sep 18, 2015
    Messages:
    182
    Likes Received:
    30
    I used to get frequent signal losses. I just did the update, I still get No Signal from time to time but now the I get the app disconnect issues. Happens on my iPhone 6 as well as an iPad mini 3.

    Hoping this thread yields a solution.
     
  6. iAm

    iAm

    Joined:
    Mar 16, 2016
    Messages:
    63
    Likes Received:
    7
     
  7. iAm

    iAm

    Joined:
    Mar 16, 2016
    Messages:
    63
    Likes Received:
    7
    I just dealt with relatively the same issue.
    I replaced the USB cable and connection problem solved.
    -I don't understand because the defective cable I replaced will still charge my phone when plugged into my charger and phone.
    But the same cable will not connect rc to phone.
    Also the USB cable was only 2 months old and used exclusively for the rc to phone
     
    #7 iAm, Mar 26, 2016
    Last edited: Mar 26, 2016
  8. Adam Papworth

    Joined:
    Jan 31, 2016
    Messages:
    6
    Likes Received:
    2
    Location:
    Perth
    I had the same problem with a cable I found it still charged my phone (iphone6) only when it was plugged in a particular way and the same when used with the P3P.


    Sent from my iPhone using PhantomPilots mobile app