Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Anyone Still using....

Discussion in 'General Discussion' started by Flyboy, Sep 22, 2013.

  1. Flyboy

    Joined:
    Jul 29, 2013
    Messages:
    266
    Likes Received:
    21
    Location:
    Michigan
    I am still using firmware 3.14 on my Phantom. Anyone else still using 3.14? Mine flies too good right now to mess with it.

    Just curious...

    Rick
     
  2. will27

    Joined:
    Jul 22, 2013
    Messages:
    53
    Likes Received:
    0
    As they say, if it ain't broke don't fix it. I work in the pro audio industry and a lot of our equipment gets periodic firmware upgrades. If it doesn't affect what our customer is doing with it, we don't upgrade. I feel the same way about this upgrade. No one has indicated that this latest upgrade will fix any of the problems that I'm concerned with. So 3.14 will remain.
     
  3. rilot

    Joined:
    Aug 18, 2013
    Messages:
    842
    Likes Received:
    5
    Location:
    Twyford, UK
    I'm on 3.14
    I did do an upgrade to 3.16 but had a flyaway so as soon as I got it back, I downgraded back to 3.14. I'm waiting for more feedback on 4.0 before I upgrade again.
     
  4. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    I'm still at 3.14 as well,
    previously I was pretty keen about updating on new updates,. but then I held out on 3.16 due to some headaches people were having,.and then they came out with 4.0 and I heard even more headaches ensued (and even DJI yanked it?).

    So I'm sticking with 3.14 until the smoke clears, as it seems to be the last trouble-free firmware they released.
     
  5. Colombus

    Joined:
    Sep 6, 2013
    Messages:
    117
    Likes Received:
    0
    Location:
    Antibes, France
    I've got my Phantom around 2 months ago with 3.14 installed. I was just about to upgrade to 3.16 when I saw all the issues that this was bringing and decided to hold.

    For the time being 3.14 is working well and I haven't had any problem, the only issue is that I am not able to activate manual mode, since the DJI assistant won't allow me to do any change until I upgrade to 3.16.

    I guess I just need to download the previous version of DJI assistant, any idea from where I could download it, since at DJI website I can see just the latest one.
     
  6. oldengineer

    Joined:
    Sep 1, 2013
    Messages:
    51
    Likes Received:
    1
    Location:
    U.K
    There's a guy on here called xstatic, he's uploaded most of the old ones. If the link below doesn't work, have a scout round here as someone else has done a similar very useful thing.

    viewtopic.php?f=3&t=1322&start=20
     
  7. discv

    Joined:
    May 7, 2013
    Messages:
    619
    Likes Received:
    26
    Location:
    London, UK
    Got my Phantom in April. I am still running firmware v 3.0 & software v 2.02 - as shipped.
    I've had no issues. But I like some of the features in v 4, once the bugs have been sorted.

    But as previous said 'If it aint broke--------' . I just do not know which way to jump :?:
     
  8. PTCX

    Joined:
    Aug 25, 2013
    Messages:
    407
    Likes Received:
    61
    Location:
    Australia
    I've not deleted any of the previous versions of the Naza software so I can open any of them and change to any version of firmware.
    Not that that does much for me since using FW 3.16.It put a bug in the IOC system and now HL and CL are unusable with every FW version.
    Now if I select Home Lock it will switch itself to Course Lock if I fly strait for 30 meters or if I make a turn.On top of that when in Course Lock all the directional controls are well and truly screwed up.As in stick forward and backward become right and left and left and right stick becomes forward and backward.
    This is the same on both of my Phantoms.One is still on 3.16 and the other is back on 3.14.
    Both are flying well so long as I leave the IOC off.
    I'm not game to try v.4.0 and not even sure if it is meant to be used on the version 1 Naza M I have.
     
  9. martcerv

    Joined:
    May 27, 2013
    Messages:
    1,002
    Likes Received:
    2
    V4.0 will work for all phantoms as it works on mine and its older then yours. :mrgreen:

    The firmware itself is pretty good minus the one pretty big bug with radius limits. Setting this well out of range and its all good, the altitude limit works well just a little odd in manual mode so for those wanting a 100% stable release best to wait for the next update as its heading in the right direction and adding some nice features but needs some bug zapping.

    Seeing as I dont have osd as yet it was good to finally get an idea of how high 100m actually is and glad to know I dont really push that level. But the police heli's fly well below 100m so I need to keep aware of them especially flying in the police paddocks as hitting one of them wouldn't be a good thing. :lol:
     
  10. PTCX

    Joined:
    Aug 25, 2013
    Messages:
    407
    Likes Received:
    61
    Location:
    Australia
    Thanks for the info Marty.
    Does the IOC work on your Phantom with v4.0?

    I also sometimes have a problem with low flying polair choppers.They like to do grid searches over the swamps in the area,I might have to do a search there myself some time. :mrgreen:

    How do you know your Phantom is older than mine?
    I have two and the second one I bought is older than my first.
    The first one had the self centering throttle and came with 3.12 FW.
    The second one did not have self centering throttle and came with 3.10 FW and an earlier serial number.
     
  11. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    I had 3.12 around 2 months and decided, upgraded to 4.00. Except for the horizontal limits issue, it works great on my January's born phantom (1th version). Just let limits in 20000m, GPS rock solid and speedy warm. 15 flights with / without loads and it is just fine.

    For those who like to "downgrade" here is my DJI's repository with older versions of Naza Assitant and its Default Phantom Parameters for each one.

    http://www.pctechsoft.com/downloads/phantom_archives/DJI-LINKS.htm
     
  12. rilot

    Joined:
    Aug 18, 2013
    Messages:
    842
    Likes Received:
    5
    Location:
    Twyford, UK
    Awesome. Very useful repository. Thanks.
     
  13. netphreak

    Joined:
    Sep 17, 2013
    Messages:
    228
    Likes Received:
    0
    You can do some URL hacking to pull up the NAZA assistant software downloads, but I don't know how many versions they still have up on the site.

    http://download.dji-innovations.com/dow ... taller.exe
     
  14. martcerv

    Joined:
    May 27, 2013
    Messages:
    1,002
    Likes Received:
    2
    I just assumed its older as you got yours after me but as stock may be old that may not be the case. Mine was 3.10 firmware or maybe older I cant remember exactly but do remember using that firmware version at one point and also no centering throttle. I will try the IOC modes and see if there is anything wrong with it on my setup.

    I dont use IOC much at all so not sure about any bugs with it, I just upgrade to a futaba 8fgs having done all the setting up and all works in naza and with a propless test plus a range test was all good. Looks like tomorrow afternoon or should I say later today lol is going to be fairly calm. So I hope to do some test flights and range tests with the new setup.

    I have lots more switches then I need but I actually do have a failsafe switch along with manual mode, gains control and all other functions setup.
     
  15. mikrob

    Joined:
    Jun 29, 2013
    Messages:
    98
    Likes Received:
    0
    I am on 3.14 & manual mode is available (though I don't use it).