Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Any one else experience this? Ideas

Discussion in 'Phantom 2 Discussion' started by Costac, Nov 26, 2014.

  1. Costac

    Joined:
    May 31, 2014
    Messages:
    48
    Likes Received:
    2
    Location:
    Costa Rica
    Yesterday my P2 flew great. This morning I updated the firmware and went out to fly. Everything seemed fine as I took off and hovered for a few seconds. Then I used left stick yawing to the right and the bird shot full throttle forward and continuing the right turn and keeping the same altitude. To get it back I had to compensate with both sticks to counteract the motion. After a few seconds, my input was causing it to fly like it should and it was reversing direction. SO it seems that the glitch was just a quick error. I brought it home and recalibrated the trans. Everything looked good and I tried flying again. Same thing.

    here is the kicker - I hooked it up to the computer again and tried to recalibrate the controls for a second time. While I was moving the left stick I noticed that the right sticks indicator was showing full input forward.

    In short, it seems like when I input yaw I am also getting full forward at the same time - all other input is normal. Anyone else have a similar issue? Fix? Thanks in advance.
    CostaC
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Do the calibration in the RC first, then then in the Assist.
     
  3. Damon

    Joined:
    Jun 25, 2014
    Messages:
    674
    Likes Received:
    5
    Location:
    Eastern Wa.
    And do a full IMU calibration on level surface.

    And do a field compass calibration before flight.
     
  4. Costac

    Joined:
    May 31, 2014
    Messages:
    48
    Likes Received:
    2
    Location:
    Costa Rica
    Thanks Guys. I tried to keep the question short so didn't add that I did compass cali + IMU cali. The thing I didn't do was an RC cali. Will try that now and let you know results.
    Thanks again
    CostaC