Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Antenna cutting out

Discussion in 'Standard/4k Discussion' started by Phazgas, Sep 1, 2016.

  1. Phazgas

    Joined:
    Jun 22, 2016
    Messages:
    12
    Likes Received:
    5
    I have a frustrating situation and I am looking for some guidance. I have P3S and have issues with the RC signal dropping out intermittently on the control side. I can be flying along, no homes open desert, and go from 4-5 bars in signal strength to signal lost/RTH instantly. I have the problem on both 1.5.7 and 1.6.8 firmware installs. I can have the loss at 300' or less and it is very intermittent. My max distance ever was over 6200' but now I am lucky to get 15-1600' with no obstructions. I am using the ARGTEK antenna. Before you say it, I have checked and rechecked the connections multiple times. The signal can cut out flying away or towards you with no warning at all. I have no loss of video signal at any time. Any advice on where to look next? Antenna on the drone looks intact and I have had no hard landings or crashes that might affect the onboard antenna. Thanks for you help.
     
  2. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,960
    Likes Received:
    1,156
    Location:
    Brookeville, MD, USA
    What cable did you use? If you used the skinny black or grey one, you might have pinched it and damaged it at some point while checking and rechecking the connections. If you crimped it too far, you could have damaged it. Or it could have just broken on its own because it's cheap.
     
  3. Phazgas

    Joined:
    Jun 22, 2016
    Messages:
    12
    Likes Received:
    5
    Outside of replacement, any suggestions? The cable covering seems intact and smooth but If it is at the connector or inside the bar where the antenna attach it will be hard to trouble shoot. Thanks for the help. Not to start a new debate on range extenders, what should I look for in the cables that connect the antennas to the internal receivers? Thanks in advance
     
  4. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,960
    Likes Received:
    1,156
    Location:
    Brookeville, MD, USA
    If your connections are sound, it seems to me it would be either a bad cable or a burnt transmitter.

    Most people say the gold cables such as this one: https://cdn-shop.adafruit.com/1200x900/852-05.jpg

    are better cables but sometimes they're hard to deal with inside a small controller because they are thicker and hard to bend and so it's harder to get the case closed...