Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Another Firmware Question

Discussion in 'Pro/Adv Discussion' started by Wmich06, Aug 20, 2016.

  1. Wmich06

    Joined:
    Jul 6, 2016
    Messages:
    41
    Likes Received:
    2
    I just got a new P3A and linked it to my other modded RC. The RC Firmware is 1.6 and the AC is 1.5.3 The app wont let me fly because the RC has newer firmware than the AC. My question is should i upgrade the AC firmaware or downgrade the RC?
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,870
    Likes Received:
    5,558
    Location:
    US
    It sounds like either option should fix the issue. I guess it depends on whether or not you're against upgrading the AC firmware.
     
    Ted4797 likes this.
  3. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,523
    Likes Received:
    1,477
    Location:
    Sacramento CA
    If your RC has 1.6, you must have 1.8 or higher on your AC. This is due to an encryption change implemented when RC 1.6 / AC 1.8 were released.

    If you leave your RC at 1.6, you'll need to update your AC firmware to 1.8 or 1.9. As @msinger noted, doing so depends on how you feel about the newer versions of AC firmware.

    If you have issues or concerns with AC 1.8 or 1.9, you can try to downgrade your RC to 1.5.7.
     
    JoBe likes this.