Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Android: Can't connect to DJI Go, Litchi works

Discussion in 'Pro/Adv Discussion' started by Mastiff, Jun 7, 2016.

  1. Mastiff

    Joined:
    Feb 14, 2016
    Messages:
    74
    Likes Received:
    4
    Location:
    Somewhere up there over Norway
    A month ago I bought a new tablet for the P3P, an Acer. It has Android 5.0.1. I have been using Litchi, but was going to try Waypoint mode in Go today. No go... (Yeah, I'm very funny! :D) I can connect directly with Litchi, but Go won't connect to the drone at all. The remote is connected no matter what, the drone reacts to sticks bottom corners to fire up the motors. Any idea what this can be? I can't remember if I have tried Go at all with the new tablet, but at least now it's not working, with the latest version of Go. Since Litchi works I know it's not the USB cable or port, it has to be software. Any idea what the reason can be?

    Edit: Solved it! I had tried to kill Litchi with apps, shutdown, and then I checked with ShutApp, but it wasn't running at all since ShutApp couldn't see it. Then I removed the USB standard for Litchi, rebooted the tablet and only chose "this once" and started Go. Turned out that it worked now. So it seems Litchi can not even have the action associated with it for Go to work. Glad I found out.
     
    #1 Mastiff, Jun 7, 2016
    Last edited: Jun 7, 2016
  2. Nicolai

    Joined:
    May 17, 2016
    Messages:
    10
    Likes Received:
    1
    My galaxy S6 I fly with will automatically set a default app (without asking or even stating it is doing so) when I plug in the phone to the RC the first time it will ask what app I would like to let access information from the cable. Either one I select will then be the only one that can connect to the craft.

    The way I have been able to get it to connect to the other is to go to the app settings (Litchi in your case) select the defaults option and then "clear defaults" then the next time I plug in it will ask which app will use the connection.
     
  3. Mastiff

    Joined:
    Feb 14, 2016
    Messages:
    74
    Likes Received:
    4
    Location:
    Somewhere up there over Norway
    Yeah, I had it set up like that with Litchi. That was the problem, and that's what I did. Except for that I had to do a reboot of the tablet.
     
  4. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,052
    Likes Received:
    1,624
    Location:
    San Francisco, CA
    It is well known that Litchi and Go app can't run simultaneously on a tablet. To make other work, you need to remove the all entirely from memory thus should not run in background too.
     
  5. Mastiff

    Joined:
    Feb 14, 2016
    Messages:
    74
    Likes Received:
    4
    Location:
    Somewhere up there over Norway
    I found that out the hard way...by not finding anything while googling, and then creating a thread before finding out what I should do myself! :D