Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Almost Went Down Again.. But now i have more info..

Discussion in 'Phantom 2 Vision + Discussion' started by SkysTheLimit, Jun 22, 2014.

  1. SkysTheLimit

    Joined:
    May 14, 2014
    Messages:
    38
    Likes Received:
    0
    Well I might of jinxed myself in my last post saying all has been well...

    But anyways as we all always quick to say "Yeah Vortex Ring Crash"... Maybe yes... Maybe No....

    So today just about the same thing happened... open field, maybe 25 feet up, been flying for about 5-10min, plenty of battery.. Then all the sudden things get weird... But this time I noticed all the Status LEDs were all solid red.. and the same almost uncontrollable state of the quad... I was unable to control it and it was coming down but on a rapid angle this time.. Like an airplane coming in for a landing.. this time i got lucky and i was able to kill the motors over some really high grass and it wasn't damaged (anymore than it was the last time, lol)...

    I take it over to a table.. lights still all solid red... i power off and on the remote.. still red.. i start it up, still red... then i try to take off (just to see what happens) it goes up crooked, wont hover in one place on its own.. its allll over the place.. like "Drunk Mode".. i land it.. take the battery out.. put it back in... then its fine.. flew it 5 more times during the day.. fine... all fine...

    Weird.. Maybe a remote calibration needed? But why fly fine then not, then fine again? Still love flying it tho.. haha.. Nothings a perfect science..
     
  2. desertphantom

    Joined:
    Mar 27, 2014
    Messages:
    22
    Likes Received:
    0
    From the manual:
    (3) If an error occurs (LED is solid red), please connect to the PHANTOM 2 VISION Assistant
    Software for more detailed information.

    1 IMU calibration is required. Calibrate within the Assistant Software.
    2 IMU is abnormal. Should be repaired.
    3 Compass is abnormal. Should be repaired.
    4 Remote controller’s mid-point is set abnormally.
    Refer to < How to solve large margin(s) mid point error?>.
     
  3. chriske

    Joined:
    May 8, 2014
    Messages:
    44
    Likes Received:
    0
    I had the same problem yesterday. I toke it down and did a compass recalibration. After that all was fine.
     
  4. SkysTheLimit

    Joined:
    May 14, 2014
    Messages:
    38
    Likes Received:
    0
    Thx.. I have a manual also.. :mrgreen: