Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Aircraft warming up forever-No IMU

Discussion in 'Phantom 3 Help' started by 2Flush, Apr 21, 2016.

  1. 2Flush

    Joined:
    Jul 30, 2015
    Messages:
    49
    Likes Received:
    7
    Location:
    Wisconsin
    Like the title says.
    I start p3 up and after about 5 seconds goes to aircraft warming up forever.
    I can in those 5 seconds click the IMU calibration. I says it in progress forever also and never does anything past 0 %
    I'm on version 1.32 and don't want to go any further. I like it.
    I can use the service bin file and downgrade all the way to 1.19 successfully, but still after about 5 seconds it just says it warming up forever.
    Only thing that has changed is I got a new battery and put in the p3 to update it and also I let my ipad off of airplane mode for a few minutes. I have it set to not update DJI go.
    It does now say that the p3 and the camera need to upgrade, but I do not want to!!

    Any ideas? Thanks..
     
  2. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Cold IMU calibration may fix this. If your last calibration was warm the IMU has to heat up to that temp before ready. Just a thought, it may not be your problem, but worth a shot.
     
    CANEKiTA likes this.
  3. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Did the cold calibration help?
     
  4. 2Flush

    Joined:
    Jul 30, 2015
    Messages:
    49
    Likes Received:
    7
    Location:
    Wisconsin
    No. The IMU buttons are grayed out during warm up which it never warms up.
    But I did put in the fridge and then tried anyway.
    Same thing.
    What I don't get is... If it's trying to warm up why would I not blow warm air on it to help it along?
     
  5. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    I know you said you don't want to do a firmware update but it might help

    Sent from my SM-N920V using Tapatalk
     
  6. 2Flush

    Joined:
    Jul 30, 2015
    Messages:
    49
    Likes Received:
    7
    Location:
    Wisconsin
    Unfortunately I think I will have to try it.

    I put it away for the winter and bring it out to fly and this crap.
     
  7. Trackman1

    Joined:
    Jan 1, 2016
    Messages:
    838
    Likes Received:
    211
    Location:
    Ontario, Canada
    I have seen other threads where people complain of P3 problem after being stored for a while.
    You could try searching along those lines.