Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

"Aircraft requires upgrade" when all updated??

Discussion in 'Pro/Adv Discussion' started by Australis5, Sep 7, 2015.

  1. Australis5

    Joined:
    Jun 16, 2015
    Messages:
    119
    Likes Received:
    34
    Location:
    FL
    Latest iOS v2.2 on iPad, just upgraded P3P firmware to 1.4, got back a "Success" in text file, yet app still showing "Aircraft requires upgrade"???

    Should I do the firmware update again?
     
    #1 Australis5, Sep 7, 2015
    Last edited: Sep 7, 2015
  2. luckbox

    Joined:
    Sep 7, 2015
    Messages:
    6
    Likes Received:
    4
    I had a similar problem . Found I had multiple copies of the old dji app running on my iPhone 6 plus . Deleted them from memory , re-ran the app and the upgrade notice had gone . Hope that helps :)
     
    Australis5 likes this.
  3. Australis5

    Joined:
    Jun 16, 2015
    Messages:
    119
    Likes Received:
    34
    Location:
    FL
    Thanks...I'll give it a go
     
  4. luckbox

    Joined:
    Sep 7, 2015
    Messages:
    6
    Likes Received:
    4
    Will also add I had to reboot the iPhone 6 plus for everything to work . Had a friend who I helped do his upgrade and he had exactly the same issue , had to delete any running copies , then deleted the app , re-installed and only when he rebooted his Ipad , everything worked as intended ... It's also worth mentioning there was no changes in the firmware on the controller itself for this version . I did waste quite a bit of time wondering why I couldn't upgrade the controller and then found a little mention in the release notes that controller firmware hadn't changed .
     
  5. Australis5

    Joined:
    Jun 16, 2015
    Messages:
    119
    Likes Received:
    34
    Location:
    FL
    My similar experience. Have never seen iOS behave like that with a simple app update. As much as it said I was on v2.2, and just gave the ability to "OPEN" in the App store (like it was already installed), once I closed all apps, and rebooted, THEN in the App store updates it showed v2.2, I updated it, then it worked. Very strange... Thanks for the heads up
     
  6. brianb87

    Joined:
    Aug 21, 2015
    Messages:
    788
    Likes Received:
    148
    Mine says same as well, even though it says it's updated.
     
  7. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    Is it the upgrade for the aircraft or for the RC it is complaining about? A few of us have discovered that our RC's were still on 1.2.6 and needed to be upgraded to 1.3.2. Once I did that its cleared up the firmware warning...
     
  8. Australis5

    Joined:
    Jun 16, 2015
    Messages:
    119
    Likes Received:
    34
    Location:
    FL
    Talking about the GO app for iOS
     
  9. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    Oh - try scanning for the app on the dji site... that did it for me....