Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Add Me to the Litchi Samsung "No Connection" list

Discussion in 'Phantom 3 Help' started by Kirby Johnson, Jun 22, 2016.

  1. Kirby Johnson

    Jun 22, 2016
    Likes Received:
    Sarasota FloriDuh
    Hi, first post:
    I am the owner of a new Phantom 3 Advanced and the Litchi software that brings out it's best.
    I purchased Litchi through the Play Store about 2 weeks ago.
    Litchi works great with my LG G Stylo phone running Android 5.1.1 .
    DJI Go works equally well on this phone also.

    I also have a Samsung Galaxy Tab S 8.4 Android 4.4.2 and a Samsung Note 4 Android 5.1.1
    The factory DJI Go app works fine on both the Note and the Tablet, but for the life of me I cannot get
    Litchi to talk to either.

    I have been through all the USB debuggin modes and 'Do not keep activities' modes, as well as Camera vs MTP vs installer. Uninstall DJI Go, reinstall Litchi only...etc for days and days.
    I have not been successful even one time getting a workable connection.
    When I turn on the aircraft and the Remote Control, the remote control boots up the phone or Tablet, and asks which App to use. But it never officially connects as evidenced by the red 'Disconnected' banner top center and the warning that it was unable to connect to DJI on the internet and verify...blah blah...

    It would be out of this world to see it on the high res Tab S. I believe I am at the limit of my technical knowledge of things Android and am asking for anyone's help. I recall seeing someone mention on here having a similar problem with a Tab S after an Android OS upgrade, implying that it worked previously.

    Thanks in Advance


  2. Discoverydave

    Jun 21, 2015
    Likes Received:
    I use a Nexus 7. Here is my startup. Turn on Tablet, turn on RC,turn on aircraft, now plug in tablet and start litchi. Hope this helps, the key is have everything started before plugging cable into tablet.