Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

ACK! RC update issues AGAIN! (solid blue LED)

Discussion in 'Pro/Adv Discussion' started by Jamsta, May 1, 2016.

  1. Jamsta

    Joined:
    Jan 18, 2016
    Messages:
    71
    Likes Received:
    8
    I have this problem on the last upgrade. DJI GO app on my Samsung S6 keeps getting "disconnected." It connects really quickly then disconnects shortly thereafter. I did the RC upgrade while it was connected but I think the app disconnected during the upgrade. The upgrade is downloaded but when I try to "upgrade" it says "failed" because I am "disconnected."

    I have tried everything including different cables, RC reset procedure, set USB settings for every possible setting, etc. Nothing has worked. RC just has a solid blue LED and app is disconnected. I can get the app to connect when I set the USB to "media share" but it quickly disconnects.

    Advice please - thanks!
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,782
    Likes Received:
    5,525
    Location:
    US
    Did you upgrade the firmware on your Phantom? If not, you'll need to do that. Also, make sure you're running the latest version of DJI GO.
     
  3. Jamsta

    Joined:
    Jan 18, 2016
    Messages:
    71
    Likes Received:
    8
    Yep upgraded the phantom firmware first. I also tried to upgrade the firmware on the RC via sd card and connected to the phantom but I never got that to work either.
     
  4. Jamsta

    Joined:
    Jan 18, 2016
    Messages:
    71
    Likes Received:
    8
    Update: I switched over to an ipad running the DJI Go app and it allowed me to download and update the RC install. This overrode the solid blue led that was rendering the RC useless. RC went through normal upgrade process via ipad. Now seems to be working on both ipad and Samsung S6.
     
    #4 Jamsta, May 1, 2016
    Last edited: May 1, 2016