Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

5 months into hobby 1600 bucks later and I had a fly away

Discussion in 'Phantom 2 Vision + Discussion' started by goatman, Mar 10, 2015.

  1. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    I cant believe this!! I went to the beach like I always do followed procedure like I always do...
    133 movies taken 66 snapshots 72 charge cycles on two batteries I'm new but I don't take chances..
    I have green lights first time , then second time , I have 8 satts fully charged batteries I take off about 60 feet or so and let off the throttle to look at the screen and hit the record button , but its not responding.. I look up and its drifting , then it excels by it self tries to go strait up I try to slow it down but no response then I pull the stick bak for it to come back to me it does but at the same time its losing altitude and bam hits the pavement at a 30* angle right on one of the arms and does a spin, the battery flies out the camera is hanging on by the wires pieces all over the place... AND I JUST BOUGHT NEW PROPS!! ****

    well when you fall down you get back up and see how much it's going to cost you.
     
  2. Julius717

    Joined:
    Sep 24, 2014
    Messages:
    548
    Likes Received:
    248
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    Naza mode or phantom mode?

    Sounds like maybe you lost GPS for a bit or possibly battery failure 72 cycles is a decent amount
     
  3. eurostylin

    Joined:
    Feb 4, 2015
    Messages:
    32
    Likes Received:
    0
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    NAZA mode? Flip S1 down one click and take over manually.

    Just posting this here for others to read as a reminder of why you should always fly in NAZA..
     
  4. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    yes its in NAZA mode

    As I sit here and see if it still works, I re attached the wires found all but one rubber stabilizer cut off some of the battery plastic so it will fit back in,I turn everything on and it still works! On the desk that is ... without the props they all spin..

    BUT as I test it I shut off the bird but the controller and wifi I pod are still on.... after about 5 minutes the controller starts beeping,I never heard this before, SO I replaced the batteries in the controller and the beeps stopped... Is this supposed to beep when the batteries are getting low? or is it an "idiot beep" to let you know after the fact that the batteries are low ..

    I am so pissed off cause if that was it....but it cant be cause I just put new ones in maybe 4 or 5 flights ago....
     
  5. eurostylin

    Joined:
    Feb 4, 2015
    Messages:
    32
    Likes Received:
    0
    Re: 5 months into hobby 1600 bucks later and I had a fly awa


    Is there a chance you put in one old battery by mistake? This will cause a rapid deterioration of the good battery.
     
  6. max

    max

    Joined:
    Sep 19, 2014
    Messages:
    199
    Likes Received:
    6
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    It beeps to remind you to turn it off after you've left it on and not connected for a long time.
     
  7. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    no old batteries

    thanks for telling me what the beeping was...
     
  8. Marlin009

    Joined:
    Dec 31, 2014
    Messages:
    1,091
    Likes Received:
    515
    Location:
    West Coast of Florida
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    The new controller beeps after 15 minutes of inactivity and will stop if you move a stick. Easy enough to test.
     
  9. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    OK I went outside all was set to fly,I took off low and it drifts like crazy,I landed it and then it excelled all by it self turned on its side and cwewed up to pros when it made contac with the pavement....something is really ffed up with this....
     
  10. n6vmo

    Joined:
    Feb 26, 2015
    Messages:
    484
    Likes Received:
    156
    Location:
    Lompoc, CA.
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    Check for a cracked GPS antenna.
     
  11. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    Im trying to get the friggin cover off but one of the screws from the impact is stripped,its the small Phillips at the end of the arm....
     
  12. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    wow this is really messed up if I start the motors they slowly excel by it self and then takes off I grabbed it and saved it...its really messed up and I never lost satts..Im pissed
     
  13. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    Try carefully drill the screw head until you can grab it out.
     
    John N Kronyak likes this.
  14. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    ok got the cover off, what a pain in the *** that was.... antenna not cracked HOWEVER I noticed the plug for the thing was loose, I only had the cover off this 1 time before and that was to change the antenna I shaved the plastic down it worked mint and I know how to solder been doing it for 30 years.... I think it may be a loose plug... I almost want to solder the friggin thing on and remove the plug..... MOTHHER*&^%%%##@@!!! you know it looks like that plug doesn't really shake hands well with its counterpart....That monkey didn't get its banana on the assembly line that day.....
     
  15. Badger55

    Joined:
    Feb 11, 2015
    Messages:
    33
    Likes Received:
    1
    Location:
    Snowed in, in Connecticut
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    If it was the plug wouldn't it have registered ZERO sats? You said you never lost sats right?
     
  16. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    I never did lose satts...Im at wits end here...I even reflashed the firmware,I never crashed this thing....and all of a sudden it has these issues..WTF??
     
  17. Badger55

    Joined:
    Feb 11, 2015
    Messages:
    33
    Likes Received:
    1
    Location:
    Snowed in, in Connecticut
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    I'm no expert here by far but to me it sounds like a controller calibration error of some kind.
     
  18. capodrone81

    Joined:
    Nov 22, 2014
    Messages:
    362
    Likes Received:
    14
    Location:
    860
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    you said you had the cover off once before to " I only had the cover off this 1 time before and that was to change the antenna shaved the plastic down it worked mint and I know how to solder been doing it for 30 years.... "

    I'm trying to understand what antenna and shaved plastic are you talking about, this might be the issue....
     
  19. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
  20. goatman

    Joined:
    Oct 7, 2014
    Messages:
    83
    Likes Received:
    9
    Location:
    mars
    Re: 5 months into hobby 1600 bucks later and I had a fly awa

    when I changed the antenna the new one is a little thicker,and on the cover there is some plastic ridges that needed to be filed down so the antenna would sit flat.

    I secured the plug and brought it outside grabbed 7 sats I stared it let it idle for a minute took off about 4 feet from the ground right where I was standing and all of a sudden it wanted to take off..luckily I had my hand loosly around one of the legs without the compass and was able to hold it while it went ballisitic... as that was goin on I tried to grab my ipod off the holder so I could film it but I was unsuccessful.. Im ready to give up I did notice that I had 1 green light then 1 red light I tried a compass reset and that didn't do it...