Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced 4 Green - 2 Red Means?

Discussion in 'Phantom 3 Help' started by Wolfiesden, Jan 20, 2016.

  1. Wolfiesden

    Joined:
    Jan 12, 2016
    Messages:
    1,187
    Likes Received:
    400
    Location:
    Milwaukee, WI, Ft Walton Beach, FL
    What does 4 short green flashes (not double green) then 2 long red flashes mean? I don't see it in the FAQ. It continually repeats that pattern. 4 green, 2 long red, 4 green, 2 long red.

    I have tried to find this pattern but don't see it listed anywhere.
     
  2. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,745
    Likes Received:
    1,092
    Location:
    Long Island, NY
    never heard of that one. are you inside or out? can you arm the motors?
     
  3. Wolfiesden

    Joined:
    Jan 12, 2016
    Messages:
    1,187
    Likes Received:
    400
    Location:
    Milwaukee, WI, Ft Walton Beach, FL
    It did it sitting indoors or out although I don't know how, its able to acquire GPS sats indoors. Freaked me out. Aluminum siding, 2 story, in the living room. Still gets GPS. Hellova GPS receiver in that bird!

    Noticed the pattern after the second flight last night. Last night was its maiden flight, FYI. So as you can imagine, I was focusing on a lot of stuff all at once and didn't notice when the pattern actually started. Noticing something out of the ordinary isn't possible for me yet since I haven't had enough experience with the ordinary :) I was getting the standard pulsing green before liftoff on the first flight or I probably wouldn't have flown until I got the pattern sorted out.

    And no, can't CSC the motors, but Lichi will auto takeoff. And it does fly. I lifted off and let it buzz for a minute or two just to see if it would.

    Earlier in the evening, I couldn't CSC the motors either nor would Lichi take off. It was due to the fact I hadn't ever run the GO app and their stupid registration process. After that, the motors would spin up just fine. Its after the 2nd and last flight that I noticed the new LED pattern and the lack of CSC. I was into GO indoors looking at settings (between it crashing that is) and generally checking out the corners of the software room to see whats in there. I have GO set to not update. But, I think I did have airplane mode off so GO could have accessed data at that time.

    Here is what the GO says in the about:
    GO: 2.4.3
    RC: 1.4.30+
    Firmware: 1.4.10+


    I am at work ATM. Will take it outside here after hours and was planning on a short dusk flight. Will report back if it still does it today. I am 30 miles from where I was last night so I can see if a change in location will alter pattern or not. If its still the same pattern, I am not sure I am going to fly out of the parking lot. I don't trust something that is trying to send a message but I don't know what that message is.
     
  4. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,745
    Likes Received:
    1,092
    Location:
    Long Island, NY
    Do the sticks work at all? If not, try rebinding the controller. Have you done stick calibration yet?
     
  5. Wolfiesden

    Joined:
    Jan 12, 2016
    Messages:
    1,187
    Likes Received:
    400
    Location:
    Milwaukee, WI, Ft Walton Beach, FL
    I will verify the sticks tonight after work. They operated just fine during 2 flights last night. But, as I said, not absolutely positive when it started this pattern.


    As for stick calibration, no, never. Did absolute minimum in GO due to it constantly crashing. I got the P3 registered. Turned off the red lights. And did an IMU cal. Thats pretty much it.

    Rest of the time I am using Lichi.
     
  6. Wolfiesden

    Joined:
    Jan 12, 2016
    Messages:
    1,187
    Likes Received:
    400
    Location:
    Milwaukee, WI, Ft Walton Beach, FL
    Well, I snuck out at lunch ;)

    Took it outside and fired it up. After warmup today, its just pulsing green. No long red flashes so I am really confused more than before.

    Also, the sticks didn't operate the bird. WTH? They did last night. I did the RC stick cal. No change. I got GO to run for more than a few minutes so I tried a takeoff with that. It did. No sticks there either. Had to grab it out of the sky by the landing struts and kill its power on the battery.

    After several more GO crashes, I managed to get into the settings. The controls were set to "Custom". WTF? When I clicked on the custom, NO operations were assigned to ANY stick axis. Thats just dumb. I reset back to mode 2. And low and behold...it responds. CSC works. It flies. Only thing I can figure is GO is a POS. Maybe it corrupted settings during one of its crashes?

    Flight after calibrating the sticks and then changing to mode 2:
    HealthyDrones.com - Innovative flight data analysis that matters
     
  7. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Get everything working in the Go App and then go to Lichi.. you will have far less "WTF" frustrations. Cheers. :)
     
  8. Wolfiesden

    Joined:
    Jan 12, 2016
    Messages:
    1,187
    Likes Received:
    400
    Location:
    Milwaukee, WI, Ft Walton Beach, FL